Subaru WRX Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello guys! I just got my WRX last halloween, brand new with 7 miles on it.

IMG_3688.jpg
IMG_3687.jpg

I dont know who owns that blue one though, just parked right next to it :cool:

It's really fun driving the car around my town, I am so much enjoying it but then one morning when I went the store to get my breakfast, then on my way back home the Check Engine Light came on with the cruise control light blinking. I stopped for a while and turned off the car thinking it might be a glitch and hoping it would go away, but nah.

IMG_3699.jpg

So I've been googling what could be the possible issue from loose gas cap to wiring which I'm not sure of, then proceeded to read the owner's manual and it says if you see CEL and cruise control blinking bring it to the dealership/service center as soon as possible and don't drive fast. Ok, I went to the dealer and the manager from the service center was shocked because its just been 60 miles and CEL came on so he went out to check the car and her proceeds to check the gas cap which is intact, never even open it because it has full tank. Now they just asked me to go to enterprise to get a rental vehicle with their expense of course but its been 3 days and I haven't heard anything from them yet like what is the diagnosis or status of the car, all they tell me is that the mechanic are still doing some testing and it is in progress. I'm getting annoyed on how they don't respond to me but when they do they just give me vague answers. Does anyone here had the same issue before?
 

·
Super Moderator
Joined
·
10,890 Posts
Well, it could literally be thousands of things. They are likely testing everything and it takes time. Multiple things could cause certain obd codes. I wouldn't worry about it because the service is free

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Welcome! Hope you figure the problem out. Not sure how to solve new car problems.
Thank you Lynnpie!



Well, it could literally be thousands of things. They are likely testing everything and it takes time. Multiple things could cause certain obd codes. I wouldn't worry about it because the service is free

Sent from my SM-G955U using Tapatalk

I know that it could be thousand of things but it's really annoying, just got the new car and its been in the service for longer than being at home/driven it :(
How long does it usually take for this kind of CEL? a week? 2 weeks? I have separation anxiety with the car now
 

·
Super Moderator
Joined
·
10,890 Posts
I have no idea what then code or the problem is so I can't say. If it requires emissions parts there is the possibility the parts had to be ordered as it's not a common failure.

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
I have no idea what then code or the problem is so I can't say. If it requires emissions parts there is the possibility the parts had to be ordered as it's not a common failure.

Sent from my SM-G955U using Tapatalk
Thanks for the info man. Hopefully I can get it pretty soon so I can drive it to work.

For the headlights (DRL) I want to change it to LED instead of halogen and getting my windows tinted, any suggestions on this?
 

·
Water.....sometimes waves
Joined
·
1,611 Posts
Mine has been doing that with the CEL and flashing cruise lights. Mine is an O2 sensor connector getting wet when it rains. I need to disconnect it and apply dielectric grease.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
Subaru just called me and they said the code was P0852 and they told me that this is a unique issue and it is basically not detecting my neutral when I shift gears and reading as I am shifting too quickly and it could be fix by a "simple" software update but they don't know when is the release date of this software. They said it is normal but once there is a high chance that it will come up again and if it does I will bring it to a different service center..
 

·
Super Moderator
Joined
·
10,890 Posts
That just came up with someone else. There is a tsb on older cars you may be able to review the tsb and ask about it

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #11 ·
I just noticed that it really doesn't detect Park or Neutral as I was watching youtube videos and on their dashboard I can see "P" when they are parked. But as for me there is no "P". I can see 1-6 when I'm shifting gears but not "P" or "N" if there is N. So I was informed this can be fixed by a software update coming in December or January, I am not sure how true that is.
 

·
Super Moderator
Joined
·
10,890 Posts
If you have a Cobb AP if I'm not mistaken it will still show gear and neutral.

Sent from my SM-G955U using Tapatalk
 

·
Super Moderator
Joined
·
10,890 Posts
I don't know that it gets much cheaper. I'd hunt down an unmarried used one personally

Sent from my SM-G955U using Tapatalk
 

·
Super Moderator
Joined
·
10,890 Posts
I would buy in person.

Sent from my SM-G955U using Tapatalk
 

·
For External Use Only
Joined
·
2,488 Posts
Just remember if you get an AP and then you have another "flashing CEL and cruise" problem, then you're really going to be waiting a while because the dealer is likely to deny your warranty claim ;)
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #20 ·
Just remember if you get an AP and then you have another "flashing CEL and cruise" problem, then you're really going to be waiting a while because the dealer is likely to deny your warranty claim ;)
Right! thank you for that info I might hold on to it for a while then
 
1 - 20 of 23 Posts
Top