Subaru WRX Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
When im at a complete stop and i go to take off. My clutch or something sounds like its grinding. And the shifts go smooth. But once i speed up and put my foot on the pedal it stutters around 4-5 rpms and then goes back to normal. And i have no idea what it is.
( I have a act heavy duty street clutch btw)

Anyone have any ideas of what it could be?
 

·
Super Moderator
Joined
·
11,442 Posts
Was the clutch broken in properly? Do you launch the car? Why do you need a new clutch on a new car? The factory clutches are quite stout.

As for the stuttering. 4 or 5 hundred or thousand? Need more information to diagnose loosely online. Why not go to the dealer where the car is under warranty?

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I launched on the stock clutch and it started to slip. Either way wanted to put a new clutch in there. And no its not under warranty anymore. Because i have a cobb cold air and invida n1 exhaust. so im pretty sure that ruins my whole warranty. And yes the clutch was broken in properly. I babied it for 400 Miles. Like act said to do. Didnt start launching the car until i hit about 900 miles on the new clutch. And yes 4k
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Forgot to mention. The stuttering parts happens past 3rd gear. From 1st to 2nd. It does not do it
 

·
Super Moderator
Joined
·
11,442 Posts
And is the car tuned for that intake?

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Super Moderator
Joined
·
11,442 Posts
Well I'm going to venture you've probably toasted it launching it.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
Thing is. I know what a bad clutch feels like. Dis doesn't feel like a bad clutch. But I'm gonna have the shop look at it to see what it could be
 

·
Registered
Joined
·
19 Posts
When im at a complete stop and i go to take off. My clutch or something sounds like its grinding. And the shifts go smooth. But once i speed up and put my foot on the pedal it stutters around 4-5 rpms and then goes back to normal. And i have no idea what it is.
( I have a act heavy duty street clutch btw)

Anyone have any ideas of what it could be?
This happens to me on a cold start. When I cruise while the car engine is still cold and I press the clutch to stop.
It makes a quick grinding/thump noise.
After the car warms up, the noise is gone. :/
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
This happens to me on a cold start. When I cruise while the car engine is still cold and I press the clutch to stop.
It makes a quick grinding/thump noise.
After the car warms up, the noise is gone. :/[/QUOTE]


I think it's my throw out bearing. I should be getting it done on monday. And have them make sure nothing else is wrong and I will let you know how it goes
 
1 - 10 of 10 Posts
Top