Subaru WRX Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
hey guys, I own a 2016 WRX; owned since late august of 2017. In a few months I've had this problem happen a few different times. Basically my car wont crank, lights and everything come on but the car wont start. Today i went to grab lunch, started up fine. Went into the restaurant for maybe 2 minutes came back and my car wouldnt start for about a minute or two. after that it started just fine. this has happened maybe 4-6 times so far owning it. Id come back to my car after work to my car not starting and having someone jump me. I got the battery and alternator tested today and all seemed well with those. So not too sure what to think of it. maybe a starter? anyone else hear about this or had anything similar?
 

·
Registered
Joined
·
370 Posts
Yeah sounds like a loose battery cable or your contacts are gunked up and need cleaning. Either way if that's not the case I'm sure being a 2016 its still under warranty and you should bring it back to your dealer and explain the situation. You can also hear a starter when you turn your key close to starting the car. Good luck.
 

·
Registered
Joined
·
691 Posts
Good luck , I had a 2015 WRX that didn't want to start when cold but was fine when warm . After 32 days in the shop Subaru bought the car back .
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Yeah sounds like a loose battery cable or your contacts are gunked up and need cleaning. Either way if that's not the case I'm sure being a 2016 its still under warranty and you should bring it back to your dealer and explain the situation. You can also hear a starter when you turn your key close to starting the car. Good luck.
Yeah I may need to bring it to the dealership. Battery cables seemed fine. Thankfully still under warranty
 
1 - 10 of 10 Posts
Top