Subaru WRX Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Per my last post, my turbo's compressor wheel was all chewed up. So I bought a steamspeed 67 and slapped it on. I have random smoke after a quick test drive, but going to assume it's the mess I made during swap. I tried a 4th gear 40mph pull to see peak boost but it was a dog. I tried and logged a 3rd gear 40mph pull and hit only about 12.5lbs. Thinking boost leak?


What should I be looking for in the logs?

Car : 15 wrx 67 steamspeed,cai,invidia exhaust,cobb v3, running stage 1 91 map

Thanks for help, new to cobb and logging.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #2 ·
Also my exhaust is pretty quiet, not sure if that's normal. I have a small suspicion that my cats are toast and clogged = not enough back pressure??
 

·
Super Moderator
Joined
·
11,442 Posts
I don’t know anything about that turbo but unless it’s a factory replacement you are going to need a custom tune
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
It's very similar to stock set up, you think the lack of a tune would prevent me from even hitting a base 15lbs?

Would hate to schedule a tune, and have them turn me away for an issue.
 

·
Super Moderator
Joined
·
11,442 Posts
Similar and the same are different. I wouldn’t drive that car until you get it to a shop
 

·
BooSTIng
Joined
·
2,288 Posts
Yikes! Turbo swap with no tune. Knock, Knock. Its your rods. Man stop driving that thing and take it to a shop. This isn't a 90's civic where you can just throw parts at it. Pretty much any aftermarket part will require a tune. Which is why most people wait until they have a whole heap of parts (similar to cobb's and other companies "staged" kits) and do it all at once. That car is UNSAFE to drive as is. And you are more than likely causing irreversible damage by driving it.
 

·
Æternum
Joined
·
15,863 Posts
Holy Jesus this was a bad move....
 
1 - 10 of 10 Posts
Top