Subaru WRX Forum banner
1 - 5 of 5 Posts

·
Registered
2013 Subaru Impreza wrx-MT
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello,
I have a 2013 wrx (mt) and I am having some problems with the AC. I just recharged it to 35-37 psi and it still will not blow as cold as it should. The other weird thing I came across was that some vents blow warmer than others. I shook my AC compressor clutch without releasing tension and it wiggled a bit. This plus the sound it is making has me thinking that it is worn out. Should I just replace the clutch or the entire unit? Or should I try and get the pressure closer to 40?
Thanks!
-Dylan
 

·
Super Moderator
Joined
·
11,767 Posts
Whats the charge supposed to be in the ac system? It needs to be charged to that. Did you draw a vacuum and make sure it didn't leak?

Is the compressor coming on and staying on? Chrysler products are known for faulty ac clutches and they will act oddly.

If you are not getting even air temp it sounds like you may have an issue with the diverter and it's still blowing air across the heater core.
 

·
Registered
2013 Subaru Impreza wrx-MT
Joined
·
9 Posts
Discussion Starter · #5 ·
I do not know the charge spec, and I’m having a lot of trouble finding it.
Yes the compressor comes on, but it sounds very rattly.
I am having more trouble finding what the diverter looks like. But if it is the part I’m thinking of, it connected to the temperature settings for the climate control. I pulled out my glove box and saw that the motor was moving but it was making a lot of noise, so maybe that is an issue.
At this point maybe I should just take it to a shop since I have never worked on AC before...
 
1 - 5 of 5 Posts
Top