ClubWRX Forum banner

Status
Not open for further replies.
1 - 15 of 15 Posts

·
Registered
Joined
·
188 Posts
Discussion Starter #1
Hey guys I just turned on my AC today after a couple days of not using it. To my surprise there was no cold air coming out. I ran it for a while and even tried to drive to see if it would change and nothing. If I put the heater on, it works fine and gets hot. It's only the cool that won't work, it just feels like a fan blowing.

I'm going to drop off the car at the dealership tonight after I flash it back to stock. Anything I should check myself before taking it to the dealer in the case it was an easy fix? I was thinking maybe a fuse? Ideas?
 

·
Registered
Joined
·
4,033 Posts
I'd just bring it right to the dealership.
 

·
Registered
Joined
·
188 Posts
Discussion Starter #3
Yeah I am taking it later tonight after I get out of work but now my brain is going all crazy thinking what it could possibly be. It only has 1000 miles so now I'm thinking about it being a lemon. I just need to tell my brain to relax I guess.
 

·
Registered
Joined
·
4,033 Posts
Yea definitely relax. This is what we have warranties for man.
 

·
Registered
Joined
·
188 Posts
Discussion Starter #5
One quick question. Do you guys here a loud clicking sound coming from under the glove box everything you turn the AC on and off? I just noticed that and am thinking it could be related to something there.
 

·
Registered
Joined
·
209 Posts
clicking noises are never natural. The AC turning on could be causing enough of a vibration maybe to giggle something? Or it is associated with your AC not working. Like fallen said that's what warranties are for, god bless them.
 

·
Registered
Joined
·
188 Posts
Discussion Starter #7
Yeah I just dropped off the car at the dealer. I will find out tomorrow what it is.
 

·
Registered
Joined
·
188 Posts
Discussion Starter #8
Just a little update, turns out I have a leak with my freon. Sucks on a brand new car.....
 

·
Registered
Joined
·
4,033 Posts
That's random.

Well, glad that you're getting it all sorted.
 

·
Registered
Joined
·
188 Posts
Discussion Starter #11
did they elaborate?Where was the leak?
Well not yet. They gave me my car back yesterday after filling the freon back up. They said it could have been low from factory(not the case) or have a leak. They could not find the leak so they put some dye in with the freon, that way they could put a black light if it were leaking to find it.

So I got my car back and thought that it would be a few weeks until it leaked out again an would have to take it back. To my surprise, by the end of last night it had all leaked out again and my car not blowing cold air again. So now I'm gonna drop it off today and they are getting me setup with a rental till they fix it. So frustrating. I think the leak is inside the car cause I could hear this hissing noise coming from the air vents when they were off. It also smelled funky and would blow out this white air initially when turning it on. So let's see what happens and I'll let you know how this turns out.
 

·
Registered
Joined
·
1 Posts
It's late now to post reply here but for such problems, look for that shop who specialized in air conditioning there you can take your car and the problem has been fixed by them.They have trained professionals which can deal with all kind of ac problems carefully.
 

·
Moderator
Joined
·
11,216 Posts
It's late now to post reply here but for such problems, look for that shop who specialized in air conditioning there you can take your car and the problem has been fixed by them.They have trained professionals which can deal with all kind of ac problems carefully.
This thread is over 5 years old.

Sent from my SM-G955U using Tapatalk
 
1 - 15 of 15 Posts
Status
Not open for further replies.
Top