ClubWRX Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I had my car at the dealer last Wednesday for routine oil change service at 11,000 miles. Car came back sounding slightly different or so I thought. Parked it for the holidays. Upon start up today my check engine, stability control and cruise control lights are all on. The cruise is the only one blinking and cannot be cleared. Any one have a similar issue with their 2011? Mine is 5door Limited in Spark Silver with Factory short shift.
 

·
Registered
Joined
·
102 Posts
I had my car at the dealer last Wednesday for routine oil change service at 11,000 miles. Car came back sounding slightly different or so I thought. Parked it for the holidays. Upon start up today my check engine, stability control and cruise control lights are all on. The cruise is the only one blinking and cannot be cleared. Any one have a similar issue with their 2011? Mine is 5door Limited in Spark Silver with Factory short shift.
When the check engine light comes line it automatically turns those two lights on. It also prevents you from using cruise control until you clear it. Since it's under warranty I'd take it back to the dealer and have them check the codes. Even if it goes away they can get what the problem was as long as you don't disconnect the battery. Also things like a loose gas cap or leaving the gas cap lid cover open will trigger it so that's the first thing to check.
 

·
Premium Member
Joined
·
25,496 Posts
dont change anything, just take the vehicle in.. Its having issues under warranty let them fix
 

·
Registered
Joined
·
3 Posts
I have the same thing with my 2011 WRX. I believe it's a sensor problem. I have brought it in twice to have it fixed.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
2011 Warning Lights

Brought the car into dealer last week. They tell me the warning lights were on due to code for cold start idler air system and asked me if I had hot the gas after starting the car when cold. I can't believe this would set off codes. Anyone heard of this?
 

·
Registered
Joined
·
7 Posts
This has been happening to me at least 10 times since I got my car in May 11. I just keep calling SOA to complain and dropping my car off. The damn lights keep coming back on after many updates to the cars software. last week 12/1/11 They sent a tech to my dealership to gather a data stream of info from the car and a fuel sample. I'll post what ever they let me know.
 

·
Registered
Joined
·
37 Posts
Today upon start check engine, cruise, trac light on, I did a battery disconnect lights still there, got code read it was p050 my cold air control valve. I have a 2011 wrx 7 mo old. I called dealer for apt cuz if this is an issue I wanted it covered for any future issues. I read another thread on this being a ecu issue as well with some 11,
But drove for about 30 min, I parked the car for 20 min went to restart and took 2 times to get her started. Waiting now for an apt with dealer.
 

·
Registered
Joined
·
7 Posts
This issue has been going on for a while with my car. It has been happening more often since the temperature has dropped. Yesterday(1/10/12) a regional tech specialist came to my garage to get a cold start reading and collect a bunch a data from my ecu. He even recorded my feet while backing out of the driveway. He told me that there are about 11 cases that he's investigating. So far they ruled out fuel as being one of the problems from a previous test. He thinks code may have something to do with the car getting a bad reading which makes it think that the rpms are too low when the clutch is engaged. Hopefully with all the data collected they can come up with a better update to re flash all of the cars with this problem.
 

·
Registered
Joined
·
8 Posts
Fantastic, my MY11 WRX just got these lights coming up on a long trip today. Had been parked up for 2 days and we had snow this morning, I drove 300kms before the lights all came up while I was on the motorway. I hope they have found a fix for it, Ski season has just started last weekend, I NEED MY REX!
 

·
Registered
Joined
·
7 Posts
A temporary update was installed 2 months ago, the lights have been off ever since. The dealer called me last week to notify me that the final update is available. I will have it installed during my next oil change.
 

·
Premium Member
Joined
·
10,822 Posts
Fantastic, my MY11 WRX just got these lights coming up on a long trip today. Had been parked up for 2 days and we had snow this morning, I drove 300kms before the lights all came up while I was on the motorway. I hope they have found a fix for it, Ski season has just started last weekend, I NEED MY REX!
Do you have a code? Any mods?
 

·
The Fruit
Joined
·
4,728 Posts
Car's this new should go right back to the dealer for warranty work. Seriously, unless the car is modded you Gents paid for a warranty there's no sense in not using it. ;)
 

·
Registered
Joined
·
8 Posts
Nah no mods, the factory warranty wont allow me to do them anyway. Im off to the dealership this morning, hopefuly its a simple error and not something major. I dont have diagnostic gear and as mangostick says its got a dealership warranty so it shall be their problem. Courtesy car included :D
 

·
Registered
Joined
·
123 Posts
My 08 has been getting strange warning lights lately. No codes though. I'm stage 2, and don't get a check engine light, just the trac off, hill assist, and ABS....car seems normal other than the lights and the fact that cruise doesn't work. Kinda worries me, but if i turn the key off and restart, it is normal again, so idk what to think about it.
 

·
Registered
Joined
·
1,134 Posts
My 08 has been getting strange warning lights lately. No codes though. I'm stage 2, and don't get a check engine light, just the trac off, hill assist, and ABS....car seems normal other than the lights and the fact that cruise doesn't work. Kinda worries me, but if i turn the key off and restart, it is normal again, so idk what to think about it.
My 09 did this. It was bought used. Former owner had messed up the steering. Car would turn one way until tires rub. Would not quite turn the other way. Steering sensor went out. Not really surprising, since the car "thinks" it's going thru a turn when it's actually going straight. Stealership replaced sensor under warranty, but took $300 for straightening out steering... No problems since.
 

·
Registered
Joined
·
123 Posts
I wonder what the sensor costs to replace. It does seem to happen after taking off and going around a corner but I'll have to pay more attention. Thanks for the input though that's really good to know.
 

·
Registered
Joined
·
1 Posts
Hey Josh, I had this exact issue in mine (MY11) Turned out to be a faulty brake light switch. Car thinks the brake lights are not working.
 
1 - 18 of 18 Posts
Top