ClubWRX Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
Hello! Long time since I posted here. I had a 2010 WRX and this had the same issue so I don't know if its the gas here in town or what.

When driven relatively moderate under WOT, 1st and 2nd gear mostly, I hear a rattling ticking sound only when the turbo spools up.

My 2010 was bad, and caused severe lag issues. Now that I traded in the 2010 for a 2011, its starting to do the same thing. I don't beat on my cars, but wondering if its a fuel issue.

Is there any bulletin on this? Only happens under load, and past 3k rpm

Darryl
 

·
Good news, everyone!
Joined
·
3,856 Posts
Could be a rattling from a heatshield or something. You're no doubt still under warranty, I'd take it back to them and tell them to fix it.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #3
That's what I thought, like a simple heatshield issue, however on my old 2010 it had lag when the sound was produced, like bogging a LOT.

I will get this checked out for sure, just wanted to get some advice before I send it in. Thank you Anubis.
 

·
Registered
Joined
·
2,606 Posts
Complete shot in the dark, but it may be what hapened to me... So please bare with me...

A couple of months after i first got my wrx i noticed a ratteling sound at WOT... Nine months later, I get a cylinder 4 misfire code and right when the light turned on i heard a light tick tick sound comming from the engine bay... After lots of deadend diagnosis, i took it into the dealership and had the engine torn down and there was my problem, a warped piston and scrached cylinder wall... Durring my research, I read that the ej255 has had a small track record for piston warping (dont get me wrong, it is not a common issue by any means) yet it sounds VERY simular to what happened to me...
 

·
Registered
Joined
·
95 Posts
Discussion Starter #5
Oh wow, good to know dude. Thank you. I'll keep this in mind. My car only has 20,000 kms (11,500 miles) on it.
 

·
Registered
Joined
·
2,606 Posts
Yeah no problem man... I'm hoping for the best for you, but your still under warranty so even if it ends up going in that bad of a situation have them install a new shortblock... I did and mine runs absolutley perfect now and restored my faith in Subaru's reliability... I am the car's 2nd owner and it was technically still under the powertrain warranty, but didn't work out in my favor... It ruined my faith in SOA, but what can ya do.... At least I tried and I got it fixed...
 

·
Registered
Joined
·
95 Posts
Discussion Starter #10
What fuel are you running?
Either Shell's 91 or most of the time - Chevron' 94.

Now, I forgot to mention that when it's colder out, there is no rattle and bog.

When its humid and warmer, it produces this sound. Don't you think that if its a heat shield it would be doing this all the time?
 

·
Good news, everyone!
Joined
·
3,856 Posts
Either Shell's 91 or most of the time - Chevron' 94.

Now, I forgot to mention that when it's colder out, there is no rattle and bog.

When its humid and warmer, it produces this sound. Don't you think that if its a heat shield it would be doing this all the time?
Not necessarily. Warmer outside temps can make things behave differently, especially rubber. It could be that the rubber exhaust hangers are changing just enough when it's warm out to allow enough movement for the heatshield to vibrate on something. Regardless though, I'd take it in to Subaru. Just tell them where it's coming from and under what conditions. Have them take you along on the drive so you can point it out to them.
 

·
Premium Member
Joined
·
25,496 Posts
Complete shot in the dark, but it may be what hapened to me... So please bare with me...

A couple of months after i first got my wrx i noticed a ratteling sound at WOT... Nine months later, I get a cylinder 4 misfire code and right when the light turned on i heard a light tick tick sound comming from the engine bay... After lots of deadend diagnosis, i took it into the dealership and had the engine torn down and there was my problem, a warped piston and scrached cylinder wall... Durring my research, I read that the ej255 has had a small track record for piston warping (dont get me wrong, it is not a common issue by any means) yet it sounds VERY simular to what happened to me...
same exact issue with my 2005 ej257
 

·
Registered
Joined
·
95 Posts
Discussion Starter #13
Not necessarily. Warmer outside temps can make things behave differently, especially rubber. It could be that the rubber exhaust hangers are changing just enough when it's warm out to allow enough movement for the heatshield to vibrate on something. Regardless though, I'd take it in to Subaru. Just tell them where it's coming from and under what conditions. Have them take you along on the drive so you can point it out to them.
Thank you! :)

But what are the chances of something VERY similar happening to my old 2010 and this new 2011? So either something mechanical and very coincidental or something simple like a heatshield.

I'll keep everyone posted!

D
 

·
Premium Member
Joined
·
25,496 Posts
I have a rattling sound in 1st & 2nd.I was told that it was the heat shield.
with what I have been thru with subaru, I would demand the heatshield be removed to prove the sound going away
 

·
Good news, everyone!
Joined
·
3,856 Posts
with what I have been thru with subaru, I would demand the heatshield be removed to prove the sound going away
Definitely this.
 

·
Registered
Joined
·
2,606 Posts
same exact issue with my 2005 ej257
Hmmm... Thats interesting since the 257 is saupose to have better pistons...

+1 on having the dealer prove its the heatshield... Just so they dont blow you off till you ou 2t of warranty and have to deal with the mind**** that is SOA customer service! I never want to deal with those $10 an hour call center twits again!
 
1 - 16 of 16 Posts
Top