Subaru WRX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I bought a 2011 WRX from a younger guy about two months ago. Managed to get it to scrape by safety, and its been bringing new problems since.

The guy supposedly had it stage two tuned, then brought it back to stockish to sell. Its got an aftermarket blowoff valve, invidia q300 exhaust, and tein coilovers otherwise.

One issue at a time the car is running rich. I swapped the MAF and it was okay for about 100 kilometers then the code came back. I checked for vacuum leaks with propane and found nothing. The idle is rough, mileage is bad and it seems to be missing power. Under heavy acceleration the revs jump up and down.

Im new to this kind of mechanic work, so any help and patience would mean a lot, thanks.
 

·
Registered
Joined
·
5 Posts
I'm no professional mechanic but it sounds to me that there is an issue with timing . So if you can find a stock 2011 ecu from a scrap yard that doesn't look modified or if you have money for an oem one swap it in . Another thing it could be is the timing belt or just the whole valve train .By the sounds of things it was a project car/daily driver so the modifications on the car would be in line with whatever modifications the previous owner had in mind . It could also be aftermarket cams that were installed that are not working very well with the lower power it is programmed to produce seeing that it was taken from a two stage to a stockish tune . Or it could also be that whoever tuned it back to its stock ish form didn't do a proper job and messed the whole thing up by not accounting for the blow off valve modifications.
Please remember that I am not a professional and that I could just be talking absolute rubbish , this is just my guess
Hope my comment helped and that your subie will be restored to its former glory.
 

·
Super Moderator
Joined
·
11,436 Posts
Do you have any data logs?
 
1 - 3 of 3 Posts
Top