ClubWRX Forum banner

1 - 20 of 117 Posts

·
Registered
Joined
·
610 Posts
Discussion Starter #1 (Edited)
I'm coming up on 1 year old this month for my sedan. I have an ongoing journal thread, but I thought it would be interesting to compile a list of similar issues that other owners have gone through the first ~12 months of ownership. Here are mine with ~17,000 miles on the odometer.

Front Bumper Crack
ABS/VDC/Hill Assist Lights (UPDATE: x2)
Rear Deck Rattles
Crazy Right Turn Signal
Subaru paint quality. The more I look at her, the more she chips!
And if you want to get really particular, the rear LED taillight went out a little too soon.

All in all, this first year has been a blast and I can't wait for many, many more. How what about the rest of you?
 

·
Registered
Joined
·
719 Posts
I have rattles and a front bumper crack. But I hit debris at 70mph so that's to be expected. I had zero rattles until I put in a 10" sub. So I'm not sure I have the right to complain :)
 

·
Wants to Sell His Honyota Civilander..Any Takers?
Joined
·
785 Posts
I'm 11 months in and other than a flat tire I haven't had a single issue with the car. No rattles for me at all. I have gotten enough light scratches on my paint that may reflect the lower quality paint they use, but nothing tragic. Hope I'm not jinxing myself but so far so good.

And of course, she has been a blast to drive. It's taken a little bit to really get a feel for a turbo motor again, and to explore the performance of the car, but I think I've hit a real comfort zone at this point, and every drive is one I look forward to.
 

·
Premium Member
Joined
·
25,496 Posts
Ive had 50 days of ownership and here are my issues:

Rough idle-near stall then idle pick up at stops

Timing belt "guides" bent rubbing timing belt ruining it in 19,000 miles ($840 later)

Subaru factory placing the A/C stretch belt on backwards (I say factory because 6 other 2011 owners sent me pics of the same issue) causing the above $840 bill to be MY bill and NOT oem warranty (FU SoA)

A Pillar/dash rattles

B pillar rattles

c pillar/rear deck rattles

Subaru Paint
 

·
The Fruit
Joined
·
4,728 Posts
^ that mess with the ac belt is complete bull.. my 2010 is a factory installed belt and is also on there exactly the way yours was Bo..
 

·
Registered
Joined
·
254 Posts
One year.
I scrached Front bumper, my bad aproach to driveway.
Driver seat lumber support got broken. They replaced it under waranty.
Thaks to livermore subaru I got loaner, till they fixed my car. Big plus to them.
Subaru paint "-"
 

·
Registered
Joined
·
169 Posts
Couple of months for me. (2012)

Minor rattle in passenger door when playing loud music with bass. Will fix one of these days.

Some a$$hole put a dent in my fender in the parking lot. Fixed for $120.
 

·
Lando Calrissian
Joined
·
3,787 Posts
11 moths here

The well known cargo cover pole rattle (will fix one of these days)

Driver's heated seat switch was bad (fixed under warranty, charge would have been $68)

Gas flap not opening as it should (fixed under warranty, charge would have been $41)

Scratches on under side of front bumper (scraped on driveway during road work)

Dent on passenger's side rear door due to an inconsiderate douche with a shopping cart last week while at the grocery store.
 

·
Gold Member
Joined
·
2,175 Posts
14 month and 16k miles

rattles...oh, the rattles. (most are my fault though - mounts, bushings, etc)
bad front blinker bulbs ("crazy turn signals") - replaced under warranty
fogging fog light - replaced under warranty
intake manifold vacuum hose popping off - clamped it, but not sure why they didn't
couple rock dings in the buttery paint (touched up a couple)
 

·
Registered
Joined
·
719 Posts
Oh wow forgot to mention the third time I drove it, 1 month after owning it the clutch went. SOA replaced under warranty. I think ah the time there was 500 miles on it

Also the USB port in the center console broke. Not sure why I had to replace that. But I paid $120 for it
 

·
Registered
Joined
·
2,136 Posts
18 months and 30k miles. My biggest complaint in the seat squeeks horrendously when it's cold. Never been to the dealer for anything yet.
 

·
Registered
Joined
·
610 Posts
Discussion Starter #12
Oh wow forgot to mention the third time I drove it, 1 month after owning it the clutch went. SOA replaced under warranty. I think ah the time there was 500 miles on it

Also the USB port in the center console broke. Not sure why I had to replace that. But I paid $120 for it
Mine is not working either. I used to be able to charge my Evo with it but one day it stopped working. It won't pick up my girlfriend's iPhone when plugged in as well. Not covered under warranty??
 

·
Registered
Joined
·
719 Posts
Mine is not working either. I used to be able to charge my Evo with it but one day it stopped working. It won't pick up my girlfriend's iPhone when plugged in as well. Not covered under warranty??
Not covered. Not sure why. My father in law who owns three subies seems to think that there was some kind of bumper to bumper no matter what it was warranty. But I didn't ask. The USB unit itself was broken. there was a piece in the middle of where the iPod cable connected to the USB internally that was busted. They fixed it but it cost me.
 

·
Registered
Joined
·
719 Posts
18 months and 30k miles. My biggest complaint in the seat squeeks horrendously when it's cold. Never been to the dealer for anything yet.
Hey! My driver side does that. But it seems like its a loose bolt. Jeeze I keep remembering these things now. Haha. What's ironic is I just don't seem to care at all. It's a fun car.
 

·
Gold Member
Joined
·
2,175 Posts
^ Yep, definitely a loose nut in the driver's seat. :p
 

·
The Fruit
Joined
·
4,728 Posts
18 months and 30k miles. My biggest complaint in the seat squeeks horrendously when it's cold. Never been to the dealer for anything yet.
My 2010 did that too.. I liberally shot every thing under the seat with silicone spray.

That was at 3500mi.. I'm now at 71,888 mi and not a peep out of it since then. Hose it down man, kill the squeaks! :wiggles:
 

·
Registered
Joined
·
2,136 Posts
My 2010 did that too.. I liberally shot every thing under the seat with silicone spray.

That was at 3500mi.. I'm now at 71,888 mi and not a peep out of it since then. Hose it down man, kill the squeaks! :wiggles:
We talked about it last year and I did what you said. It worked for the remainder of the winter but it is now back so I'm planning on a respray
 

·
Registered
Joined
·
392 Posts
Timing belt "guides" bent rubbing timing belt ruining it in 19,000 miles ($840 later)

Subaru factory placing the A/C stretch belt on backwards (I say factory because 6 other 2011 owners sent me pics of the same issue) causing the above $840 bill to be MY bill and NOT oem warranty (FU SoA)
Forgive the stupid question but how can I tell if mine is on backwards?
 

·
The Fruit
Joined
·
4,728 Posts
heh.. yeah, non-directional belt. No way to actually put it on "backwards" .....
 
1 - 20 of 117 Posts
Top