ClubWRX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey i have a 2005 subaru impreza and i am having problems with my fog lights. I just bought the fog light kit that is made for a stock 2005 impreza. it came with the relay button and lights. i pluged the lights and everything in and when i press the fog light button my high beams come on?
things you may need to know:
-i have hid lights installed on my low beams
-i pluged the relay into the 2nd position from the bottom (under dash fuse box)
 

·
Pro Manscaper
Joined
·
21,455 Posts
well...I'm sure the HIDs have something to do with that...wiring is no longer stock.
 

·
Premium Member
Joined
·
17,655 Posts
I don't think it has to do with HIDs.

Double check the fuse panel to see if you have it plugged in to the correct relay.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I don't think it has to do with HIDs.

Double check the fuse panel to see if you have it plugged in to the correct relay.
all my fuses are good. and im pretty sure the relay is in the right spot i found that out from other forums....
 

·
Lando Calrissian
Joined
·
3,787 Posts
maybe your HIDs are plugged into the relay that the fog were meant to use. Unfortunately, you're likely going to have to trace the wiring for the HID kit as well as the fog kit and compare it to the factory correct wiring diagram. Likely not a fun job...especially in the winter cold. :(
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
ya no kidding. the Hid's are pluged into a sepreate relay i bought that plugs into my stock system. but ya i think i could figure it out with a diagram. Anyone got a wiring diagram for a 2005 impreza rs?
 
1 - 7 of 7 Posts
Top