ClubWRX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I bought my 2002 wrx around a year ago and the past 5 months I have had on and off problems with the car turning over but not starting. The car is completely stock and so far I have replaced the fuel pump, spark plugs, crankshaft sensor, and camshaft sensor. When it does start it runs perfect. I am out of ideas and was wondering if anyone has any ideas. Thanks
 

·
Registered
Joined
·
10 Posts
hmm thats a tough one try replacing the the fuel pump fuse first!!!, the if that does not fix it it possible its you fuel sensor or your 0^2 sensor! what plugs did you replace it with and did you do it your self or did a shop do it? are there any mods?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
The fuel pump turns on. The last time my car did not start I drove it home and then went to start it 5 hrs later and it would not start. However I just walked out to it and turned the key and it started right up. I replaced the plugs with ngk iridium at stock gap. And I have no mods.
 

·
Premium Member
Joined
·
6,501 Posts
I am assuming no DTC's/CEL? Unfortunately this is going to be a PITA to diagnose. I would start by cleaning all engine grounds and re-torquing them. Next would be checking the various sensors (crank,cam,ignition circuit) for voltage and ground. Obviously the fuel pump is easy to tell because you can hear it prime when you turn the key to "on".
 

·
Registered
Joined
·
226 Posts
Ah the good crank no start check battery alternator and starter systems make sure your starter is drawing enough amperage to turn it over and your alternator is putting out enough juice to do it, could be low compression, sounds like the timing aspect of it is ok with the cam and crank sensor and your getting fuel from the new fuel pump. be sure not to flood the enigine cranking and cranking it.
 
1 - 5 of 5 Posts
Top