ClubWRX Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
i was doing a u turn and i got back on it and wtf no power feels like its stoped up or something any help pleas :sadwave:
 

·
Registered
Joined
·
54 Posts
i was doing a u turn and i got back on it and wtf no power feels like its stoped up or something any help pleas :sadwave:
How about more info. Or what happened 2 minutes down the road.
How much gas did you have? When the last time you changed the filter?
Could of been a fluke? Did it ever happen again?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
its a 2002 wrx bone stock a did a u turn in some lil rocks with the gas to the floor then i put it in 2 gear then then thats when it happend :sadwave:
 

·
Banned
Joined
·
0 Posts
Every peice of info you have pleas.

I had a similar problem withing the first day of getting my car. How long have you had the car? Any mods?
 

·
Banned
Joined
·
0 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #7
yea thats me but i did not hook up the mbc i was going to wait tell i get a bigger turbo but this **** happen :sadwave:
 

·
Registered
Joined
·
106 Posts
without more info, no one can really offer advice. all we know is that you made a u-turn, you hit the gas, and you didn't go very fast. that's not very informative, so right now all we can do is speculate.
 

·
Banned
Joined
·
0 Posts
without more info, no one can really offer advice. all we know is that you made a u-turn, you hit the gas, and you didn't go very fast. that's not very informative, so right now all we can do is speculate.
+1

Do you have a boost gauge. Is the car boosting. Do you have any cels. Are you just messing with us. How many miles are on the car. What your feelings on the matter are? Are you angry are you sad? Does the lack of power leave your life feeling empty, void mabey. ANYTHING
 

·
Registered
Joined
·
24 Posts
Discussion Starter #12
i found it,it was the stock bov i took the bottom hose off of it just to make it blow off and i paid for it lol :screwy:
 

·
Banned
Joined
·
0 Posts
i found it,it was the stock bov i took the bottom hose off of it just to make it blow off and i paid for it lol :screwy:
K thanks for a complete waste of 112 people who viewed this. Seriouslly though are you just messing with people.
 

·
Registered
Joined
·
25 Posts
You removed the return line just to hear the "whoosh" sound? I did the sensible thing, I got a Cobb intake. Seriously though, don't just randomly remove hoses. It doesn't turn out well.
 

·
Registered
Joined
·
1 Posts
I think its his tires. Sounds like he needs the ones that smoke different colors when you drift...
 

·
Registered
Joined
·
0 Posts
K thanks for a complete waste of 112 people who viewed this. Seriouslly though are you just messing with people.
So let me get this straight - the OP started pulling hoses under the hood, and then couldn't figure out why the car wasn't running well?

The lesson - know what you're doing before you start messing with stuff under the hood of your car.
 
1 - 19 of 19 Posts
Top