ClubWRX Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i just got a 2002 wrx 219k on car 75 k on the motor and new turbo and i beleve this to be true as i saw the invoices and talk to the dealer that did the work.
my problem is the car had bad boosting when i got it only would pull 7 psi. its all stock but the bov. i have only gotten 1 code to come up it was a lean bank one code .
so i pulled all the hoses off the intercooler the bov intake and bcs cleaned everything replaced all the hoses that didnt look good made shore the pill was in the write hose off the wastegate replaced the plugs checked the coils cleaned out the intercooler and rebuilt the bov saw it had a small leak. now the car runs great till boost hits hears where im lost.
1st it only pulls 5 psi in 1st then in 2nd 3rd and 4th it will pull 5 then i regas it and it will 5 to 10 then drops back to 5 psi then under wot it will boost to 17 psi out of no ware im stuck on what to do moneys low so replacing parts right now is hard but i dont beleave its a parts problem as most everything iv read on this forum iv tried. please help sorry for the long post tried to give as much info as i could to help thank you
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
now i got everything running good but my boost it jumps to 5 psi then up to 15 16 psi the drops down to 5 psi again. up down up down only mods is magnaflowmuffler and after market bov im thinging that the bov is leeking some how going to try and rebuild it again this time with washers this sound right anyone
 
1 - 2 of 2 Posts
Top