ClubWRX Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Got a 2001 bug eye wrx last week and fited a decat up pipe and decat ellmouth downpipe of ebay yesterday.
The car went better but the exhaust is making a ticking noise in the down pipe, almost sounds like theres something in it! Also getting a lot on noise with any amount of boost, Is this because the waste gate is not blanked off???
And also after driving it today the engine management light just come on!
Anyone got any experiences with these problems?
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
29,233 Posts
Search "CEL fix" and make sure you have no leaks.
 

·
Would Never, Ever Say Something Bad About an Admin
Joined
·
5,780 Posts
Got a 2001 bug eye wrx last week and fited a decat up pipe and decat ellmouth downpipe of ebay yesterday.
The car went better but the exhaust is making a ticking noise in the down pipe, almost sounds like theres something in it! Also getting a lot on noise with any amount of boost, Is this because the waste gate is not blanked off???
And also after driving it today the engine management light just come on!
Anyone got any experiences with these problems?
What type of engine management are you you using.
 

·
Would Never, Ever Say Something Bad About an Admin
Joined
·
5,780 Posts

·
Registered
Joined
·
314 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #7
so what i need to do? could this light be because of the 02 sensor?
i was thinking of getting an ecutek remap but want to get a different downpipe to hopefully cure the noise from the bell mouth i now have. maybe a twin dump system?
 

·
SuperNova
Joined
·
11,904 Posts
Search "CEL fix" and make sure you have no leaks.
Theres your answer.

What type of engine management are you you using.
You are gonna need something. I think Unichip makes something for your application. There is always opensource tuning, ecutek, or the old school Fuel controller, knock timing retard, and boost controller option.

Not standard anymore, now the exhaust has no back-pressure like it did when it was standard
Yup.

well it looks like your next buy is some sort of EM, whether it be a Cobb AP or Utec... etc
Those are for NORTH AMERICAN SPEC SUBIES ONLY. Wont work on the rest of the world.
 

·
SuperNova
Joined
·
11,904 Posts
so what i need to do? could this light be because of the 02 sensor?
i was thinking of getting an ecutek remap but want to get a different downpipe to hopefully cure the noise from the bell mouth i now have. maybe a twin dump system?
Light is on cause of the O2 sensor. Ecutek map will work and your DP is fine. The "noise" is most likely a "fluttering" sound. It is normal. It is your wastegate operating.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
So theres no way of getting rid of that fluttering noise or at least making it quieter?
I wat thinking of blanking the waste gate side of like the stock downpipe or maybe weld a separating partition in.
Im shure not all exhausts make this noise, sometimes it sounds like the engines ratling!
 

·
SuperNova
Joined
·
11,904 Posts
So theres no way of getting rid of that fluttering noise or at least making it quieter?
I wat thinking of blanking the waste gate side of like the stock downpipe or maybe weld a separating partition in.
Im shure not all exhausts make this noise, sometimes it sounds like the engines ratling!

Yes it is quiet loud, nothing you can do about it, accept get a louder muffler. Only way to stop it is too take off your turbo, or sell your car. Make sure your exhaust gaskets aren't leaking.

DO NOT BLANK IT OFF LIKE THE STOCK DOWN PIPE. You will have officially ruined your DP and any performance gain you netted.
 
1 - 13 of 13 Posts
Top