Subaru WRX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
2017 WRX premium MT with 2,200 miles. Starting hearing a random pinging noise recently and seems to be getting worse. Car is stock. Completed recommended engine wear in with oil change at 1,500 miles. Never red lined, launched, or beaten. Was running 91 octane but last few tanks were 93.Took to dealer today and took tech for ride. Wasn't too loud but he heard the noise. He had no clue recommended dropping off for few days so they could check it out.

Pinging noise occurs only while driving. Seems more prominent when letting off throttle. Dissipates with acceleration and engaging clutch as rpms drop. Seems to be coming from engine or engine components. Cannot reproduce with reving engine at stand still. Car seems to have normal power and acceleration and otherwise runs fine with no check engine lights.

The video is poor quality. Used old iPhone then could not get video off so recorded off that phone but you could still appreciate the noise. Hopefully it will upload.

Anyone with similar issue or input? https://cloud.tapatalk.com/s/58f81fd741121/20170419_205853_001.mp4


Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
75 Posts
Damn thats a good one... I hope you get it figured out. Sounds like an experienced mechanic will have to check this one out in oerson. Probably disasemble the engine or give you a whole new one. Use that warranty to its fullest.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
Damn thats a good one... I hope you get it figured out. Sounds like an experienced mechanic will have to check this one out in oerson. Probably disasemble the engine or give you a whole new one. Use that warranty to its fullest.
Thanks, I really hope it's something simple. Last thing I want is to rip apart a brand new car.

Sent from my SM-G900V using Tapatalk
 
1 - 5 of 5 Posts
Top