Subaru WRX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I got an 11 wrx motor blew and rebuilt but now motor won’t crank over. Timing is correct fuel pump is kicking on motor gets fuel. Head lights dash lights radio alarm system works but when I turn the key no crank. Just a single click kind of like the sound of a relay. Tried jumping to get power same thing no crank. Alternator is good starter is good got both tested. 1 Battery works on multiple different cars to start. Other battery using needs to be jump to turn on dash light and radio. I can’t figure out what the problem is. HELPP!
 

·
Super Moderator
Joined
·
10,985 Posts
Starter solenoid? Do you have an aftermarket security system?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
No after market security system. STarter was tested and drive engages so don’t think that it’s the solenoid. Not sure if that makes a difference though
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
19,598 Posts
Check all the earth connections I bet you've left a mains off somewhere. Also, I can't work out what this sentence means:

Other battery using needs to be jump to turn on dash light and radio. I can’t figure out what the problem is.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I’ve triple check every connection there is. All the grounds are there all the wiring harness is connected.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
I’ve used two batteries the one in the car is dead needs to be jumped to get a charge or any lights to come on. My other battery is brand new and charged fully. Sorry about the confusion
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
All the ones that made sense to check looked at the owners manual just to double check which one were which none of them are popped. Haven’t checked every relay currently but I don’t think it’s that.
 
1 - 8 of 8 Posts
Top