Subaru WRX Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
To avoid reviving an old thread, this is where I originally posted my issue within this forum: 08 WRX Engine Stalls, no CEL
My original thread was created in NASIOC, and it's where I'm still updating: 08 WRX Engine Stalls... No CEL - Page 2 - NASIOC

To continue on that note, here's what I found:

I think I've finally found the issue. It's been 2 days with no issues, so I'm still a bit skeptical, but given what I found, I feel a bit more confident.

So, as always, I get a stall. This time the car was inside the garage. I was replacing the windshield washer nozzles because they were clogged, and the P/S pump leaks a bit, so I was filling it up. I turned the car on to circulate the P/S fluid a bit when I got the stall. The Temp needle pegged at high, dash lights on, etc., etc. I started messing around with plugs and relays below the dash to see if anything I touched made a difference in behavior, but nothing changed.

I have an additional ECU because I'm planning on doing the cloning process with Karmann Auto in Portland, so I decided to plug that one in, knowing full well that it wouldn't turn on. When I plugged it in, everything was normal, temp needle normal, scanner could read the ECU, but the Security light was ON, which I know is because VIN numbers in the ECU's don't match. I plug the OEM back in, Temp needle back to high, dash lights, etc. At this point I decide to pull the ECU out and just open it to see if I could find any visible issues on the ECU board. Guess what... I did! Have a look at the pics below:





I only took these 2 pics, but apart from that there were several small points with visible corrosion and even liquid residue trails, basically starting below the plugs and running across the board where it could by gravity.

I did as I've done with PC's, consoles and laptop motherboards... I dosed the board with alcohol and gave it a good clean with a toothbrush. All corrosion was removed, but the chip I show in one of the pics might need some of the pins to have the solder reflowed to make sure everything has good contact.

As I said above, it's only been 2 days, but given that no hiccups or stalls have happened, the issue was completely random, and the Cobb AP no longer flashes while I'm turning the key, leads me to believe the issue was poor contact between the ECU board and the chips. I have been forcing the car a bit these past 2 days because, even though I can't recreate the issue on command, it's mostly common at WOT and when drive over 4K RPMs, and there hasn't even been a hint of the issues.

Now, what could've caused this? When the issue started, a few things happened. I had replaced the clutch, the A/C was worked on, and something else I don't remember (it's been 5 years since this started). My theory has always gone back to the A/C, as in something got broken or wrongfully connected when it was worked on. I've removed the dash 3 times for loose connections or anything. I do remember at some point finding the hose for condensations that connects to the blower motor loose, just hanging there. At that moment I didn't put much thought into it as the issue wasn't still happening, but seeing where that hose hangs when loose, and the position of the ECU, makes me think that at some point that hose might have dripped condensations over the ECU. Yes, there's a thick carpet and the ECU has a metal plate over it, but at the angle the ECU sits, and the dried liquid trail I found inside it tells me that at some point water or a liquid was dripping over the plugs. The trail starts below the plugs and ends at the bottom of the ECU given it's orientation.

So, I'll keep testing. As I said, I'm still a bit skeptical. I'm preparing to reflow the solder on the points shown in the pics, so when I get another chance at removing the ECU, and have the tools necessary to do this kind of work, I'll work on it and maybe show before and after pics.

Until then...
 
1 - 1 of 1 Posts
Top