Subaru WRX Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
My 2004 Subaru WRX has been revving up and down by itself when it warms up but when I just start it before it warms up it idles high I replaced my maf sensor, intake air sensor, map sensor and hasn’t changed a thing please help me. Thanks
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #2 ·
My 2004 Subaru WRX has been revving up and down by itself when it warms up but when I just start it before it warms up it idles high I replaced my maf sensor, intake air sensor, map sensor and hasn’t changed a thing please help me. Thanks
Also it stalls when I plug the maf sensor in.
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
19,724 Posts
If it stalls with valid input from a working MAF sensor it cannot adjust fueling.

What mods have been done?

Have you cleaned the IACV?

Which way does the MAF harness face?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
Not sure as far as mods go I just bought the car, I just bought a brand new maf sensor and it still does the same thing and the harness faces towards the back
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Not sure as far as mods go I just bought the car, I just bought a brand new maf sensor and it still does the same thing and the harness faces towards the back
It has a Cobb accessport stage 1 tuned atm and it has a jdm ej205 motor in it has a cold air intake but that’s all I know
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
If it stalls with valid input from a working MAF sensor it cannot adjust fueling.

What mods have been done?

Have you cleaned the IACV?

Which way does the MAF harness face?
If it stalls with valid input from a working MAF sensor it cannot adjust fueling.

What mods have been done?

Have you cleaned the IACV?

Which way does the MAF harness face?
Not sure as far as mods go I just bought the car, I just bought a brand new maf sensor and it still does the same thing and the harness faces towards the back
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
19,724 Posts
The MAF is installed backwards. The harness should face the nose of the car.

That is a problem, so definitely fix that. There could be others though.

See if the car now runs -- but we are still left with a list of potential modifications that we'd need to know about to help best.

Post back when you have results from the MAF correction.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
The MAF is installed backwards. The harness should face the nose of the car.

That is a problem, so definitely fix that. There could be others though.

See if the car now runs -- but we are still left with a list of potential modifications that we'd need to know about to help best.

Post back when you have results from the MAF correction.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #10 ·
The MAF is installed backwards. The harness should face the nose of the car.

That is a problem, so definitely fix that. There could be others though.

See if the car now runs -- but we are still left with a list of potential modifications that we'd need to know about to help best.

Post back when you have results from the MAF correction.
If so then the cold air intake is backwards ? It looks like it’s right to me maybe I was thinking differently then you were saying do you mean the wires facing the front or the plug facing the front of the car ? I tried flipping the maf sensor around and it doesn’t line up with the holes so I’m not sure what you mean by that
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
19,724 Posts
The wires must face forward.

In the daytime, make a list of the mods. The intake isn’t authentic Subaru. There may be other issues too — can’t tell with that photo though.

A clear pic of the engine would help get responses.

I’m guessing the car isn’t mapped for the mods.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #12 ·
The wires must face forward.

In the daytime, make a list of the mods. The intake isn’t authentic Subaru. There may be other issues too — can’t tell with that photo though.

A clear pic of the engine would help get responses.

I’m guessing the car isn’t mapped for the mods.
Okay so yeah the sensor is in right but I’ll post a pic in the morning of the engine
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #14 ·
The wires must face forward.

In the daytime, make a list of the mods. The intake isn’t authentic Subaru. There may be other issues too — can’t tell with that photo though.

A clear pic of the engine would help get responses.

I’m guessing the car isn’t mapped for the mods.
How would I map my car for the mods it has ?
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
19,724 Posts
You'd find out what those mods are -- in addition to the intake -- and either hire someone, DIY, or buy a device that supports those mods specifically with a map (like an AP).

I suspect the car had more mods that were removed for sale.
 
1 - 15 of 15 Posts
Top