ClubWRX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2003 WRX with about 62k miles. As I was driving last night, when the car was in 3rd, I was flooring it a little bit and if I remember correctly I heard a loud thump and my car went out of gear. Afterwards it was impossible to get the car back into any gear. My friend said it could be my hydraulic clutch cylinder. The previous owner installed an aftermarket racing clutch, which I know have shorter life spans, so does my clutch sound like the problem here?:confused:
 

·
Registered
Joined
·
6,751 Posts
Your slave cylinder could definitely be the problem. What exactly happens right now if you try to put it into gear?
 

·
Registered
Joined
·
37 Posts
Not to jack this but where there any "symptoms", if you will, before this all of a sudden happened because my 03 grinds going into first unless I easy it in or wait for it to almost fall into place as I put a little pressure on the shifter
 

·
Registered
Joined
·
6,751 Posts
I'd check your shifter linkages to make sure it's actually connected correctly.

To the last poster, if you don't want to jack, then you should be starting your own thread. And you shouldn't be jacking because people don't tend to answer you when you do...
 

·
Registered
Joined
·
37 Posts
I wasn't trying to jack it. I was seeing if be may have had previous problems leading up to it and if what they're going through now is something I should expect or may happen to mine, my apologies.
 
1 - 6 of 6 Posts
Top