Subaru WRX Forum banner
1 - 8 of 8 Posts

·
Registered
2002 Subaru Impreza WRX
Joined
·
7 Posts
Discussion Starter · #1 ·
Alright so here's the deal I bought this car knowing it was gonna be work so this is me reaching out for some assistance on figuring this subaru stuff out
Its supposedly a JDM EJ205 with a new harness and ecu

So it wasn't running when I bought it he was driving and it turned off on him, he couldn't get it started he replaced the battery and gave up I guess??

So I had it running for 2 days, I charged the battery up stuck it back in and started it up, ran fairly well until warmed up and would idle at 500 rpm or slightly less. Drove it around the block and to the gas station and back no real issues.
Went to start it up today to show my father how it was running, and started for a good 45 seconds or more then suddenly died and refused to start.

So now what its doing is when the key is in the ignition and switched on the fuel pump doesn't sound, will crank but not start. The check engine light is gone, then when key is in the off position and/or out the fuel pump sounds off the oil light flickers very dimly and the pump continously runs until I disconnect the battery.

One last thing ill add, when I depressed the gas pedal angrily once the check engine light that normally is on when the key is in the on position comes back slightly and flickers, I got it to stay solid one time and the fuel pump came back on properly and it almost started heard it catch and fired for a second but then the check engine light disappeared again and the fuel pump went back to running while the key ilwas out.

Any help would be greatly appreciated, I'm new to subarus and I want to learn more
 

·
Super Moderator
Joined
·
11,607 Posts
You said the previous owner butchered the wiring harness, and by proxy probably fiddled with the ecu as the USDM ecu doesn't support avcs. I'd start by looking up a wiring diagram and finding what's different. is the ecu a USDM version?

It's really nearly impossible to gauge anything on JDM engines. They are rarely what's advertised and quality is dubious at best.
 

·
Registered
2002 Subaru Impreza WRX
Joined
·
7 Posts
Discussion Starter · #3 ·
You said the previous owner butchered the wiring harness, and by proxy probably fiddled with the ecu as the USDM ecu doesn't support avcs. I'd start by looking up a wiring diagram and finding what's different. is the ecu a USDM version?

It's really nearly impossible to gauge anything on JDM engines. They are rarely what's advertised and quality is dubious at best.
The harness itself doesn't look terrible, they supposedly replaced it with a new ecu and harness and wired in the avcs. Though honestly I don't know what the difference to look for in the ecu would be, probably something I should look up
 

·
Super Moderator
Joined
·
11,607 Posts
You can't wire in the avcs as the USDM ecu doesn't support it. So they likely have a JDM ecu mated to the vehicle. I'm not entirely familiar with this swap, but I'd check the usuals like relays, but the dash lights in not sure, if a scan tool will read it, that may shed some insight.
 

·
Registered
2002 Subaru Impreza WRX
Joined
·
7 Posts
Discussion Starter · #5 ·
Actually tried an OBII reader, couldn't get it to connect to the car, wouldn't read anything. Also something I forgot, when I had it running the mileage trip reset every time I turned the car off whether I went 1 mile or .2 miles it always reset back to zero when turned off

Do have a suggestion on which relays to chase down first?
 

·
Super Moderator
Joined
·
11,607 Posts
I don't think the dash readout has anything to do with the ecu.

Not off the top of my head. A Google search should yield some factory service manuals. I'd start there and start with wiring. More times than not these swaps are half assed wiring spaghetti knots.

I'd attempt to identify the ecu. If it's USDM and scan tools don't work you've got a wiring issue that you will have to manually trace. If it's JDM I'd source a USDM. I believe you can run it on a JDM 205, verify this before going balls deep, but you'll lose the avcs so it'll leave a little on the table when out of boost. Enough to matter? Probably not.
 

·
Registered
2002 Subaru Impreza WRX
Joined
·
7 Posts
Discussion Starter · #7 ·
Thank you, I found the service manual online. Hopefully it has the different wiring diagrams for the usdm and jdm I haven't looked through it yet, ill start there and see what I find
 

·
Registered
2002 Subaru Impreza WRX
Joined
·
7 Posts
Discussion Starter · #8 ·
I don't think the dash readout has anything to do with the ecu.

Not off the top of my head. A Google search should yield some factory service manuals. I'd start there and start with wiring. More times than not these swaps are half assed wiring spaghetti knots.

I'd attempt to identify the ecu. If it's USDM and scan tools don't work you've got a wiring issue that you will have to manually trace. If it's JDM I'd source a USDM. I believe you can run it on a JDM 205, verify this before going balls deep, but you'll lose the avcs so it'll leave a little on the table when out of boost. Enough to matter? Probably not.
Update

So I potentially have figured out the cause of the problem, I was watching some YouTube videos on people with similar issues when I found a guy with a 04 with the same issue. Turns out it was a loose ground on the motor. Gonna check again in the morning and see what happens
 
1 - 8 of 8 Posts
Top