ClubWRX Forum banner

o2 sensor

  1. Upstream O2 sensor changed...now gray smoke?

    General Maintenance, Troubleshooting & Accidents.
    So after installing a new Bosch upstream sensor, and doing a full oil change, I've gotten some gray smoke coming from the passenger side of the block. It's not thick at all, if it wasn't for a red light I wouldn't even have noticed it. It doesn't really smell like anything, which is odd. It's...
  2. Oxygen Sensor for Import

    International Forum
    Hi Guys, I know there are a ton of posts about oxygen sensors, but i havent been able to find what I need. I have a 99 WRX JDM version and it is really hard to find the right o2 sensor here in aus. I have managed to find the right part number etc by calling the dealership in New Zealand. I...
  3. wrx eratic idle, CEL list. tryna figure this out..P0851, P1153, P1152..

    General Maintenance, Troubleshooting & Accidents.
    05 wrx, stage 1, catback, cobb intake Fixed my power issue (stock uppipe was clogged by a broken apart cat... :( ) so i played safe and got a used td04 mated to a 2.5in catless UP. Now im having these weird a** idle issues...cold start the car idles up to around almost 2.5k then drops and sits...
  4. Engine codes!! O2 problems, help!!

    General Maintenance, Troubleshooting & Accidents.
    I recently put on a full 3" exhaust, down pipe and one piece up pipe/UEL header. Two days after the install my 03 2.0 wrx died in the middle of an intersection. It will run but anything past 1/4 throttle/2k RPM seems to bog the motor. Now it wont run long enough to get it out of the driveway...
  5. Check Engine, Traction Control, Cruise Control Faults

    New Member Introductions
    WRX Forum, I've been getting all three faults simultaneously: check engine, cruise cuise control (doesn't work, the light keeps blinking on and off), and traction control light comes on and will not work. The diagnostic machine reads the check engine fault as O2 sensor bank 1, sensor 1. My...
  6. Wideband O2 Sensor install location

    Tuning: Electronic Engine Management
    Hello guys, I installed a PDX wideband sensor in my 07 STI, but there were a couple of conflicting parameters to define its location: First, it says that you have to locate it at least 18" after the turbo because if not the heat will eventaully burn it (better yet, 36" if you are going to...
  7. access port and front o2 sensor

    Tuning: Electronic Engine Management
    ok I am new but hear me out. I have headers and uppipe and the front o2 sensor will not screw in properly due to oversizing of the up pipe. evedently the o2 sensor tip rests against the piping? does this make sense? Anyways I had this done when i replaced my motor... another story... Damn...
  8. trouble code: PO172.. o2 sensor

    Motorsports Talk
    i just got an 02 subi wrx from an auction.. it has some mods, hks turbo 3" turbo back exaust by invedia, (deleted cat) aps intercooler.. its throwing this code PO172.. bank 1 rich condition. possibilities: 1) faulty fuel press reg. 2)faulty map. sensor 3)o2 sensor i believe since it doesnt...
  9. 02 wrx misfires and runs rich

    General Maintenance, Troubleshooting & Accidents.
    well my 02 wrx has been misfire and running rich for a while.at first i thought it was the spark plugs which stopped the misfires on 2 3 and 4. but still misfires, but when its going up hill in 4th or 5th gear the cel will flash for about 5 seconds and not stay on and in all the times Ive reset...
  10. Can't figure out what's wrong

    Tuning: Electronic Engine Management
    My car has this hesitation stutter while in first gear between 1k and 2.5k rpm. The acceleration sucks as well. My CEL came on and I hook a diagnostic machine up to my ECM and the code read bank 1 sensor 1 too lean. So I changed my a/f upstream o2 sensor, and then got my ECM reset and my CEL...
  11. O2 Sensor below threshold - P0420 code triggers the Check Engine Light

    Tuning: Electronic Engine Management
    New member here with an on-going issue: Car: 2008 WRX Hatchback Issue: O2 Sensor keeps tripping after installing the following: Subaru 08-UP WRX/STI With High FlowCat. Down-Pipe Subaru 2008 WRX HatchBack N1 Cat-Back Cobb AccessPort (this had to be sent back as it would not flash ECU... still...
Top