ClubWRX Forum banner

maf

  1. General Maintenance, Troubleshooting & Accidents.
    Have a new (to me) used 08 wrx wagon. Ok so I have a yellow front o2 sensor like older year wrx's and newer sti's but the factory sensor for my car appears to be blue. They also look a lot different on the end. Are they all the same? Judging by the picture I would think they arent.. The reason...
  2. General Maintenance, Troubleshooting & Accidents.
    I'm at my whits end. I finished building a hybrid engine. Ran great for the first 200 miles. The problem occured driving home when the driverside wheel unbolted itself and shredded up the front wire harness(no lines were severed but about 15 fused together). Never trust a friend to torque your...
  3. Engine Modifications
    So i just bought a cobb air box, intake, and post MAF hose. Im wanting to get a nice turbo inlet hose because my current one is falling apart and really causing idling problems! So im just wondering would the Perrin one be a good buy? Here is the link to the exact one...
  4. General Maintenance, Troubleshooting & Accidents.
    Heres the deal guys, I need to pass emissions next week with my 2002 WRX and my CEL won't go off after trying many things. Im pulling up code P0102 for low voltage to MAF. I've replaced my filter and MAF sensor and looked for leaks and I havent been able to find anything. However, i just noticed...
  5. General Maintenance, Troubleshooting & Accidents.
    I have a 2006 Wagon WRX with 85k Miles on the clock. The car is all stock. It has been running a little rough at idle and stutters under acceleration. After a stutter or two the car seems to pick up and pull pretty well. I have read lots of threads about similar problems and decided to check...
Top