Subaru WRX Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-4 of 5 Results
  1. General Maintenance, Troubleshooting & Accidents.
    Two days ago my car started bogging down when on the throttle, particularly while under boost. For a while it rarely happened but last night the car popped a CEL and cut itself off while coming to a stop. I’ve checked the gas cap to see if it’s something as simple as that but that doesn’t seem...
  2. General Maintenance, Troubleshooting & Accidents.
    Hello, I just came back from the dealership after taking it in due to a CEL that would intermittently come on and off. I checked the codes and saw that it was an issue with the TGV and MAF sensor. I got my car back within a few hours and they just told me that they tightened the negative...
  3. New Member Introductions
    First off I’m new here so if this is the wrong spot my bad. Now I just bought this car it’s an 02 wrx wagon with the 2.0 turbo with 5 speed trans. The only things done to the car is a Cobb down pipe and catback besides that it’s all stock. My first issue is no matter what code reader I plug into...
  4. General Maintenance, Troubleshooting & Accidents.
    Hey everyone I have a 2010 STI hatch and recently it got a code for a P0172 System to Rich, and when I first start it up it starts to misfire but goes away after idling for awhile, then when around 3500 rpm it sputters anyone have any ideas on what it could be? Thanks for your help
1-4 of 5 Results
Top