Check engine ligh 03 wrx
Results 1 to 7 of 7

This is a discussion on Check engine ligh 03 wrx within the Tuning: Electronic Engine Management forums, part of the Tech & Modifying & General Repairs category; My check engine light came on and I have a full tb exhaust and cool accessport map stage 2 running ...

  1. #1
    Registered User
    Join Date
    Oct 2013
    Location
    wichita ks
    Posts
    46

    Check engine ligh 03 wrx

    My check engine light came on and I have a full tb exhaust and cool accessport map stage 2 running so the light has been off since I downloaded the map but now my check engine light is on after about 4 months of having the engine management. Should I re flash the map? The accessport is saying my heater control circuit is low.also on my tripple pod gauges the oil press guage is below the zero and in the red but no oil light is on. Please help

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User WRX-maniac's Avatar
    Join Date
    Sep 2013
    Location
    Western Maryland
    Posts
    557
    Exactly what code is it throwing and what does it say. We'll need this to properly diagnose the problem here. I believe the code is P0031. But make sure thats what it is, also is it bank 1, sensor 1; sensor 2, etc. ???
    2011 WRB WRX hatchback---Stage 2
    Stink-Eye Mob #301
    http://www.clubwrx.net/forums/builds...ld-thread.html <----Build Thread

  4. #3
    Registered User WRX-maniac's Avatar
    Join Date
    Sep 2013
    Location
    Western Maryland
    Posts
    557
    Most of the time this means you have a faulty o2 sensor, or the wiring to the o2 sensor is damaged or has a short in it.
    2011 WRB WRX hatchback---Stage 2
    Stink-Eye Mob #301
    http://www.clubwrx.net/forums/builds...ld-thread.html <----Build Thread

  5. #4
    Registered User
    Join Date
    Oct 2013
    Location
    wichita ks
    Posts
    46
    Yes, p0031 and bank 1 sensor 1. If it was the o2 sensor I didn't think the check engine light would even come on? That's one of the reasons for the cobb ap I thought?

  6. #5
    Registered User Obeisance's Avatar
    Join Date
    Apr 2012
    Location
    Ann Arbor
    Posts
    300
    This link has a lot of info about troubleshooting that code. I've used it myself to much success.

    http://www.scoobymods.com/showthread...82f6a39e5&amp;

    There's a problem solving table that helped me a lot. I ended up replacing the sensor at a little over 90 kMiles, which is a normal lifespan for it.
    David - '05 WRX

  7. #6
    Registered User WRX-maniac's Avatar
    Join Date
    Sep 2013
    Location
    Western Maryland
    Posts
    557
    Quote Originally Posted by vaugghann View Post
    Yes, p0031 and bank 1 sensor 1. If it was the o2 sensor I didn't think the check engine light would even come on? That's one of the reasons for the cobb ap I thought?
    The AccessPort does not enable codes from popping up. If something goes wrong, for example your o2 sensor, you will still get a CEL. The accessport will only allow you to read the code and clear it. The only way to actually disable a CEL code from popping up is if a tuner actually programs your car to do so. The link that Obeisance posted will further explain things on how to fix it.
    2011 WRB WRX hatchback---Stage 2
    Stink-Eye Mob #301
    http://www.clubwrx.net/forums/builds...ld-thread.html <----Build Thread

  8. #7
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    12,947
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by WRX-maniac View Post
    The AccessPort does not enable codes from popping up. If something goes wrong, for example your o2 sensor, you will still get a CEL. The accessport will only allow you to read the code and clear it. The only way to actually disable a CEL code from popping up is if a tuner actually programs your car to do so. The link that Obeisance posted will further explain things on how to fix it.
    Actually, not quite. Cobb stage 2, for example, defeats a number of codes regarding catalyst efficiency.
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •