O2 sensor plug n play questions
Results 1 to 2 of 2

This is a discussion on O2 sensor plug n play questions within the Tuning: Electronic Engine Management forums, part of the Tech & Modifying & General Repairs category; alrighty, yesterday i decided after a huge amount of diag and testing(15 minutes checking connections) that my 144k mile upstream ...

  1. #1
    Registered User tirerob's Avatar
    Join Date
    Nov 2012
    Location
    bug-eyeing in the Bakken
    Posts
    917

    O2 sensor plug n play questions

    alrighty, yesterday i decided after a huge amount of diag and testing(15 minutes checking connections) that my 144k mile upstream o2 sensor just needed to be replaced. yup it sure did, the change in the way the motor runs is amazing. but now i am curious.

    is it just the location of the plug or does the upstream o2 have a direct affect on the ebcs? it seems that i have more consistant boost. going by ear and butt dyno, no guages (installed) just yet. but really, it does drive quite a bit, stronger maybe?
    when my friends come up, i hear, "you sold the camarrrroooh.....HOLY BLEEP A WRX!"
    Ya has that effect on me too.
    Rob

    Where did he go?? http://www.clubwrx.net/forums/builds...ll-thread.html

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User wreckingball man's Avatar
    Join Date
    Jul 2012
    Location
    Rocky Top
    Posts
    2,272
    I dont think the front o2 is used while under boost.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •