Problems with PA emissions after installing a TBE?
Results 1 to 3 of 3

This is a discussion on Problems with PA emissions after installing a TBE? within the Tri-State forums, part of the Regional Discussion category; Im thinking of installing a TBE (probably with catted DP). Has anyone had problems with visual and / or sniffer ...

  1. #1
    Moderator   Sasquatch's Avatar
    Join Date
    Apr 2004
    Location
    Southeastern PA
    Posts
    31,156
    I Support ClubWRX

    Problems with PA emissions after installing a TBE?

    Im thinking of installing a TBE (probably with catted DP). Has anyone had problems with visual and / or sniffer tests in PA having a modified exhaust?

    Thanks!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Aug 2004
    Location
    Allentown, PA
    Posts
    79
    for my emmissions test i had on a catback....no problems at all...BRIAN

  4. #3
    Registered User
    Join Date
    Jun 2002
    Location
    Eastern Pennsylvania
    Posts
    59

    Re: Problems with PA emissions after installing a TBE?

    Originally posted by 04.SPT.WRX
    Im thinking of installing a TBE (probably with catted DP). Has anyone had problems with visual and / or sniffer tests in PA having a modified exhaust?

    Thanks!
    As long as you don't have any CELs on you should pass with flying colors.

    I have an APS uppipe, and BPM TT turboback with 1 hi-flow cat and I have passed 3 years straight.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •