someone want to help me out? - Page 2
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 16 to 30 of 30

This is a discussion on someone want to help me out? within the Tri-State forums, part of the Regional Discussion category; the only thing is that it seems to run a little better when its cold outside. when it makes the ...

  1. #16
    Registered User
    Join Date
    Mar 2010
    Posts
    35
    the only thing is that it seems to run a little better when its cold outside. when it makes the coughing sound its coming from somewhere around the turbo. ive checked the live data on my ap and my afr stays the same even through the rough spot. if i floor it it gets through the rough spot easier. it makes it really hard to drive on the highwway because i have to either stay below 2700-3000 rpm or above or else it gets really rough. its getting very frustrating. i want to get my car out and drive it but it frustrates me that my car doesnt run as smooth as it should.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User
    Join Date
    May 2008
    Location
    Philly area
    Posts
    74
    Quote Originally Posted by KandyWRX02 View Post
    the only thing is that it seems to run a little better when its cold outside. when it makes the coughing sound its coming from somewhere around the turbo. ive checked the live data on my ap and my afr stays the same even through the rough spot. if i floor it it gets through the rough spot easier. it makes it really hard to drive on the highwway because i have to either stay below 2700-3000 rpm or above or else it gets really rough. its getting very frustrating. i want to get my car out and drive it but it frustrates me that my car doesnt run as smooth as it should.
    Very odd man....I can fully understand your frustration. sounds like it might be a tuning issue though, of course there's so many other things that can play too....afraid I don't have any answers as much as ideas I guess. Do you have access to a data logger to determine if you are in closed or open loop mode when this happens?
    03 Mazdaspeed Protege
    Currently:
    Custom SRI, Custom FMIC with HKS SSQV, GHL 3" down & midpipe with hi-flo cat, stock boost on Garrett T-25, crossdrilled & slotted rotors w/ stainless steel brakelines, Custom projector headlights w/ CCFL rings & LEDs, Reverse cowl CF hood, Prosport boost & water temp gauges, AWR motor mounts, NGK Powerdex Wideband O2, ....still more to come....

  4. #18
    Registered User
    Join Date
    Mar 2010
    Posts
    35
    no i dont. when i bought the car it had the issue. the dealership adjusted the fuel pressure cuz it was off and i knew i would need a tune. when i get it tuned the hesitation was still there but it wasnt nearly as bad. i could have got used to it. but as time went on it got worse. i tried reflashing the map numerous times and nothing. the turbo shootout at beaver springs is coming up in 2 weeks and i want to run my car but i dont want to run it the way it is. the only thing i can think of doing is taking off all of my intercooler piping and making sure everything is put back on tight. and also go over all vacuum lines. ive searched the web to see if i can find someone else that has had the same problem but there is nothing! the only way i can think of knowing where coughing noise is coming from exactly is to take my hood off and have someone risk their life to hang themselves out of my passenger window to see if they can see where its coming from lol

  5. #19
    Registered User
    Join Date
    May 2008
    Location
    Philly area
    Posts
    74
    wondering if maybe your wastegate or BPV/BOV is failing....that's the only other thing I can think of after mulling it over for a few days. Wish you the best of luck!
    03 Mazdaspeed Protege
    Currently:
    Custom SRI, Custom FMIC with HKS SSQV, GHL 3" down & midpipe with hi-flo cat, stock boost on Garrett T-25, crossdrilled & slotted rotors w/ stainless steel brakelines, Custom projector headlights w/ CCFL rings & LEDs, Reverse cowl CF hood, Prosport boost & water temp gauges, AWR motor mounts, NGK Powerdex Wideband O2, ....still more to come....

  6. #20
    Registered User
    Join Date
    Mar 2010
    Posts
    35
    well the bov is pretty new. its an aps 50\50 bov. yesterday i unplugged the map sensor and it seemed to run better but still had hesitation. it seems to be getting worse and im going to contact some tuners and see if they have any idea.

  7. #21
    Registered User Steveo47193's Avatar
    Join Date
    Jul 2008
    Location
    Sunbury, Pennsylvania, United States
    Posts
    355
    how often do you clean your maf sensor? Dont know if that is the problem just throwing that out there lol
    Blobeye Syndicate #43

  8. #22
    Registered User
    Join Date
    Mar 2010
    Posts
    35
    i tried that already. i was hoping to get it out for the riverwoods car show but with it running like crap and not having a dash i dont know if it will be worth it.

  9. #23
    Registered User
    Join Date
    Mar 2010
    Posts
    35
    ive been doing some research and im going to try and replace the fuel filter so see if that gets me anywhere. im hoping i figure this problem out so i can post it on here incase someone else ever ends up with this same problem.

  10. #24
    Registered User
    Join Date
    Mar 2010
    Posts
    35

    update

    i replaced the fuel filter and nothing happened. i pulled the map sensor plug out and it ran a lot smoother but still had hesitation. so i read up on what the map sensor does and im 99% sure thats my problem. im hoping i can find an auto parts store that has one in stock. im keeping my fingers crossed lol

  11. #25
    Registered User
    Join Date
    May 2008
    Location
    Philly area
    Posts
    74
    Quote Originally Posted by KandyWRX02 View Post
    i replaced the fuel filter and nothing happened. i pulled the map sensor plug out and it ran a lot smoother but still had hesitation. so i read up on what the map sensor does and im 99% sure thats my problem. im hoping i can find an auto parts store that has one in stock. im keeping my fingers crossed lol
    Good luck to you & keep us posted on how it works out for you
    03 Mazdaspeed Protege
    Currently:
    Custom SRI, Custom FMIC with HKS SSQV, GHL 3" down & midpipe with hi-flo cat, stock boost on Garrett T-25, crossdrilled & slotted rotors w/ stainless steel brakelines, Custom projector headlights w/ CCFL rings & LEDs, Reverse cowl CF hood, Prosport boost & water temp gauges, AWR motor mounts, NGK Powerdex Wideband O2, ....still more to come....

  12. #26
    Registered User
    Join Date
    Mar 2010
    Posts
    35
    bought a map sensor from subaru. surprisingly they were the cheapest! my car runs a lot smoother. although if i dont have it floored theres still some hesitation and at 3k rpm every once in a while it makes the coughing noise still. im thinking the wastegate might be having issues. ill figure it out sooner or later lol

  13. #27
    Registered User
    Join Date
    Jan 2010
    Posts
    22
    Quote Originally Posted by KandyWRX02 View Post
    bought a map sensor from subaru. surprisingly they were the cheapest! my car runs a lot smoother. although if i dont have it floored theres still some hesitation and at 3k rpm every once in a while it makes the coughing noise still. im thinking the wastegate might be having issues. ill figure it out sooner or later lol
    is your boost guage dropping at all like it cant hold the boost?

  14. #28
    Registered User
    Join Date
    Mar 2010
    Posts
    35
    Quote Originally Posted by book1989 View Post
    is your boost guage dropping at all like it cant hold the boost?
    yes it is but only for a split second and it jumps back up. you can hear air being released and it only does this when im at around 3k rpm.

  15. #29
    Registered User
    Join Date
    Jan 2010
    Posts
    22
    Quote Originally Posted by KandyWRX02 View Post
    yes it is but only for a split second and it jumps back up. you can hear air being released and it only does this when im at around 3k rpm.
    i would check for a leak in air

  16. #30
    Banned
    Join Date
    Sep 2009
    Location
    PA
    Posts
    21
    Maybe go to NASIOC and check the 2.0L forums. ClubWRX is only good for it's local forums and it;s dopey OT.

    BTW, from what it sounds like, your car's tune is the problem.

+ Reply to Thread
Page 2 of 2 FirstFirst 12

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •