Clutch rusty squeal noise.
Results 1 to 14 of 14

This is a discussion on Clutch rusty squeal noise. within the Transmission & AWD forums, part of the Tech & Modifying & General Repairs category; I have a '12 WRX Cobb ots stage 2 w/ catted DP. I went to the track last night and ...

  1. #1
    Registered User DwnShft4WRX's Avatar
    Join Date
    May 2012
    Location
    NorCal
    Posts
    39

    Clutch rusty squeal noise.

    I have a '12 WRX Cobb ots stage 2 w/ catted DP.

    I went to the track last night and did some hard launches between 4000 and 4500 rpm; I was slipping the clutch. This morning, car is cold and haven't been started or driven since I got home last night, I depressed the clutch and noticed this rusty squealing noise. I haven't noticed this noise prior to my track time. I will be driving my car today to see if I notice any clutch or transmission issues; but, if someone notices this same noise, please let me know.

    https://www.youtube.com/watch?v=iPzHSW9n7D0
    When life passes you by, DownShift! - DSC

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    1,483
    its possible the grease for the shaft got burnt up. before listening to the vid I thought it was going to be the TOB.
    that's my first and only guess though, since it makes the noise everytime you engage and disengage the clutch. have not heard that noise yet.

  4. #3
    Registered User DwnShft4WRX's Avatar
    Join Date
    May 2012
    Location
    NorCal
    Posts
    39
    Much thanks for the response "nsibanez." Any other input will be greatly appreciated. I just need to know if there is something I have to do, repair wise.
    When life passes you by, DownShift! - DSC

  5. #4
    Registered User 386WRX's Avatar
    Join Date
    Jan 2014
    Location
    Port Orange Florida
    Posts
    360
    Mine sounds the same. Mine continues to sound like that until I depress it. No idea what it is. Subscribed

    Sent from my LG-E980 using Tapatalk

  6. #5
    Registered User
    Join Date
    Apr 2012
    Location
    Columbia, MD
    Posts
    55
    u ever figure it out?

    when did it make the noise? when u were coming home from the track so it was HOT. or the next day when it was Cold

  7. #6
    Registered User DwnShft4WRX's Avatar
    Join Date
    May 2012
    Location
    NorCal
    Posts
    39
    Nope, never figured it out and I'm not sure what to take apart so I'm just gonna have to wait til it get's worse.

    The noise was noticed the morning after I came from the track. So the entire car was cold (stored in garage).

    I just really hope it's nothing serious. As of right now, it drives no problem but I did notice that the usual stiff clutch feel is no longer there.
    When life passes you by, DownShift! - DSC

  8. #7
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    1,483
    I've noticed mine acts up in the rain..After its been raining a while. I think it's the firewall flexing in all honesty. You can hear it from the cabin but it's louder outside from the engine bay

    Sent from my SCH-I545 using Tapatalk

  9. #8
    Registered User
    Join Date
    Apr 2012
    Location
    Columbia, MD
    Posts
    55
    if its when its cold hes right. the first thing i would look at is the firewall. theres alot of videos on utube for where to check. its in the same spot for most people.

  10. #9
    Registered User DwnShft4WRX's Avatar
    Join Date
    May 2012
    Location
    NorCal
    Posts
    39
    Would you be so kind as to link said videos for me to review? Thanks.
    When life passes you by, DownShift! - DSC

  11. #10
    Registered User
    Join Date
    Apr 2012
    Location
    Columbia, MD
    Posts
    55

  12. #11
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    1,483
    Takes five minutes to check. You'll need to remove your wiper arms, plastic cowel, and the motor. I think there's 6 welds all together. 4 of mine broke

    Sent from my SCH-I545 using Tapatalk

  13. #12
    Registered User DwnShft4WRX's Avatar
    Join Date
    May 2012
    Location
    NorCal
    Posts
    39
    Checked the clutch master against the firewall and found no cracked welds or movement. Still unsure what is causing the noise. Car drives fine tho....
    When life passes you by, DownShift! - DSC

  14. #13
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    1,483
    Quote Originally Posted by DwnShft4WRX View Post
    Checked the clutch master against the firewall and found no cracked welds or movement. Still unsure what is causing the noise. Car drives fine tho....
    It's not against the master, the spot welds are under the wiper motor

  15. #14
    Registered User DwnShft4WRX's Avatar
    Join Date
    May 2012
    Location
    NorCal
    Posts
    39
    Checked the spot welds yesterday and found no signs of breakage, movement, or rust. Weird thing is, the rusty squealing clutch noise is gone. Don't know if it was nothing to begin with, problem fixed itself, or I'm just waiting for something major to happen...frustrating.

    I know. People will probably say "take it to the dealer;" but I've had horrible past and recent dealer service experiences that are making me avoid them.
    When life passes you by, DownShift! - DSC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •