clutch making bad sounds
Results 1 to 5 of 5

This is a discussion on clutch making bad sounds within the Transmission & AWD forums, part of the Tech & Modifying & General Repairs category; i have 2004 with turbo back, intake and cobb AP (s2). i was using launch mode and let it out ...

  1. #1
    Registered User
    Join Date
    Mar 2012
    Location
    carroll county MD
    Posts
    3

    clutch making bad sounds

    i have 2004 with turbo back, intake and cobb AP (s2). i was using launch mode and let it out at 4k, it made a bad sound when i released the clutch..im just hoping i did not mess up the transmission.. i could still drive after but i could feel the clutch slipping big time..i could still move the sifter into all the gears like normal.. my machanic cant start on it for a week or so and i was hoping some one could give me some peace of mind about weather i need a new transmission..i have done some reading and seems like i should get a stock clutch kit. i would really appreciate hearing what you all think i did to my baby. thanks again

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    MAINEiac 11blackSTi's Avatar
    Join Date
    Nov 2012
    Location
    Portland, ME
    Posts
    2,377
    I Support ClubWRX
    Quote Originally Posted by gibbes007 View Post
    i have 2004 with turbo back, intake and cobb AP (s2). i was using launch mode and let it out at 4k, it made a bad sound when i released the clutch..im just hoping i did not mess up the transmission.. i could still drive after but i could feel the clutch slipping big time..i could still move the sifter into all the gears like normal.. my machanic cant start on it for a week or so and i was hoping some one could give me some peace of mind about weather i need a new transmission..i have done some reading and seems like i should get a stock clutch kit. i would really appreciate hearing what you all think i did to my baby. thanks again
    Sounds like you cooked your clutch at the very least. Once you get it fixed stop launching the car!

  4. #3
    zax
    zax is online now
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    11,735
    I Support ClubWRX I Support ClubWRX
    Doh.
    2015 CWP WRX STi on order ... But how did I get roped back into an EJ motor?!
    Zax' Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    The REAL 'WTF Tuning?!' Progenitor
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero | Blobeye Synd. #Tree-Fiddy
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  5. #4
    Registered User
    Join Date
    Mar 2012
    Location
    carroll county MD
    Posts
    3
    Thank you for the response..how about the pressure plate?..is that something that can be replaced alone if the rest of the clutch is in good shape?...i think the clutch has 25k on it...everything was perfect till i did the launch . i had never dumped up untill a few weeks ago when i got the AP..i think i dumped it a total of 6 or 7 times..never more than 5rpm

  6. #5
    Registered User MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    7,581
    I Support ClubWRX
    At 25k I would want to replace the friction disk and resurface the flywheel as well.. probably a good idea to replace the TOB while you're in there too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •