Clutch vibration
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on Clutch vibration within the Transmission & AWD forums, part of the Tech & Modifying & General Repairs category; Hey guys, I have a 13 hatch with 800 miles on it and today after getting off the highway I ...

  1. #1
    Registered User Scoob1318's Avatar
    Join Date
    Apr 2013
    Posts
    142

    Clutch vibration

    Hey guys,

    I have a 13 hatch with 800 miles on it and today after getting off the highway I noticed when I went to push my clutch in it was vibrating/had a gritty feeling. It was like that the whole way home through all the gears. When I parked the car and left it running I was pushing the clutch in and out and there was no vibration but as soon as I give it a little gas it vibrated and it's pretty noticeable. Is this a normal wear thing that happens? Or should I take it in to the dealer. This is my first manual car so I don't know if something is wrong with the clutch or if this is normal.

    I should mention that getting in and out of the gears is still smooth, it's just the clutch pedal.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User ProZach626's Avatar
    Join Date
    Aug 2008
    Location
    St. Louis Metro East, on the Illinois side, but not the really bad Illinois side, but also not the really good side.
    Posts
    326
    I know what you mean about the 'gritty' feeling. My 13 sedan does that too, sometimes. If it bothers you, just let them know at your next oil change. That's what a warranty is for, bro.

  4. #3
    Registered User Scoob1318's Avatar
    Join Date
    Apr 2013
    Posts
    142
    Yea my thought was to see how it acts over the next few weeks, and when I get an oil change ill bring it up. I just want to make sure I'm not damaging any thing

  5. #4
    Registered User mcdbrendan's Avatar
    Join Date
    Dec 2011
    Location
    Boulder, CO
    Posts
    853
    It will go away shortly, mine has done this in the past and it always goes away after a few drives. If it doesn't, take it in to the dealer.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •