2011 wrx tranny problem
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on 2011 wrx tranny problem within the Transmission & AWD forums, part of the Tech & Modifying & General Repairs category; i have a 2011 wrx sedan and recentaly went stage 2 with the cobb AP. i have an invidia catless ...

  1. #1
    Registered User
    Join Date
    May 2012
    Location
    San Antonio, TX
    Posts
    14

    2011 wrx tranny problem

    i have a 2011 wrx sedan and recentaly went stage 2 with the cobb AP. i have an invidia catless downpipe invidia q300 CBE and AEM intake. i went to the track this past weekend and dumped the clutch at take off and got a really bad smell of burnt clutch, after that my clutch feels alot "lighter" ive tried taking off in 1st gear fast to check for slipping but i havent noticed any slipping also the clutch gets stiff randomly. Anybody ever had this problem or have an idea what it could be??

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    2,270
    careful, our cars tranny are weak and overly sensitive to dumping the clutch

  4. #3
    Registered User mcdbrendan's Avatar
    Join Date
    Dec 2011
    Location
    Boulder, CO
    Posts
    853
    Sounds like a driver problem, not a tranny problem. These cars aren't made for hard launches by dumping the clutch - if the tires can't spin (AWD), something else has to.

  5. #4
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    2,270
    someone told me the five speeds in japan arent as crappy and weak as ours are

  6. #5
    Registered User EndlessSea's Avatar
    Join Date
    Nov 2012
    Location
    Las Vegas
    Posts
    423
    Quote Originally Posted by nsibanez View Post
    someone told me the five speeds in japan arent as crappy and weak as ours are
    k.......????????

  7. #6
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    2,270
    it means our versions are slacking

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •