Clutch pedal feels "notchy"? Help! - Page 2
+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 37

This is a discussion on Clutch pedal feels "notchy"? Help! within the Transmission & AWD forums, part of the Tech & Modifying & General Repairs category; They said it was a bushing inside the car for the clutch pedal that wasn't properly lubricated. So we'll see ...

  1. #16
    Registered User Dzanga's Avatar
    Join Date
    Oct 2011
    Location
    phx
    Posts
    255

    Clutch pedal feels "notchy"? Help!

    They said it was a bushing inside the car for the clutch pedal that wasn't properly lubricated. So we'll see if that's actually the problem. And if that fixed it. I will update you after a day or two of driving it around.
    2012 Wrx SWP Hatch-Traded
    2013 Limited ISM Hatch -Current

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    21,203
    "Oh Evan, we need more luuuuuuuuuuubee"
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    ProcessWest TMIC Cobb SF Intake w/airbox Invidia Catless Downpipe Invidia Q300 Catback Kartboy Short Shifter
    OpenSource tuned by: Matty @ WTF Tuning

  4. #18
    Registered User Dzanga's Avatar
    Join Date
    Oct 2011
    Location
    phx
    Posts
    255

    Clutch pedal feels "notchy"? Help!

    Lube always seems to do the trick haha
    2012 Wrx SWP Hatch-Traded
    2013 Limited ISM Hatch -Current

  5. #19
    Registered User
    Join Date
    Mar 2012
    Posts
    57
    sounds good, but i dont see why it would go away when the car warms up if its in need of lubrication? if we have the same issue

  6. #20
    Registered User Dzanga's Avatar
    Join Date
    Oct 2011
    Location
    phx
    Posts
    255

    Clutch pedal feels "notchy"? Help!

    I though the same thing because mine would only happen once in awhile and after a few pumps it would go away. But so far after they lubed it I have had no issues where I usually would. I was surprised. Does your clutch still engage normally?
    2012 Wrx SWP Hatch-Traded
    2013 Limited ISM Hatch -Current

  7. #21
    Registered User
    Join Date
    Mar 2012
    Posts
    57
    yep clutch engages just fine, and clutch seems to have decided to feel normal again..

    anybody know exactly where said bushing is located? I'd like to give it a shot and try lubing it, my car isnt exactly dealer friendly lol

  8. #22
    Registered User Dzanga's Avatar
    Join Date
    Oct 2011
    Location
    phx
    Posts
    255

    Clutch pedal feels "notchy"? Help!

    Mine isn't either unless you got some crazy stuff going in haha but it is supposedly the one in the cab the service guy made it sound pretty simple. I havent had a chance to check it out
    Last edited by Dzanga; 10-19-2012 at 05:53 PM.
    2012 Wrx SWP Hatch-Traded
    2013 Limited ISM Hatch -Current

  9. #23
    Registered User
    Join Date
    Mar 2012
    Posts
    57
    nothing too crazy, just fmic, downpipe, and other bolt ons, dont wanna risk them saying something though lol

  10. #24
    Registered User mgmoehn's Avatar
    Join Date
    Jun 2012
    Location
    Peoria Area - IL
    Posts
    105
    My clutch pedal does the same thing. After researching I found a thread on NASIOC and one guy said it was his master cylinder leaking. I could not find repeatable information though but there seems to be a lot of people with the same clutch pedal vibration/notchy feeling.

    I just took mine in at the dealer and it does not do it on the way to the dealer or during the investigation drive. Mine happened after driving on the highway for a couple hours, i downshifted to get on off ramp and noticed a really weird resistance from the clutch pedal. Clutch engages normally just the pedal feels like there is an air leak or something
    2012 WRX Hatchback ISM - Base Model - STI STS, SPT Boost Gauge, AEM Intake, TP Stage 1 Tune, red illumination kit, cobb shift knob, 20% tint - currently on stock wheels wrapped in Pirelli Winter Carving Edge Tires
    Some cool tidbits to come...

  11. #25
    Registered User Dzanga's Avatar
    Join Date
    Oct 2011
    Location
    phx
    Posts
    255

    Clutch pedal feels "notchy"? Help!

    Ok so a day or two after the "bushing fix" the same problem comes back and I schedule an appointment to take it back. On the test drive the problem comes up for the tech and now he says its the throw out bearing and lucky for me they don't care about mods here and they are going to fix I for free. Apparently they have already fixed it but since I had to get a rental car I can't pick it up until tomorrow so hopefully it is fixed now. Oh and I only have 14000 miles and I do know how to drive a clutch. He said its rare for this to happen but he has seen it a few times. Hope this helps
    2012 Wrx SWP Hatch-Traded
    2013 Limited ISM Hatch -Current

  12. #26
    Registered User JEV361's Avatar
    Join Date
    Aug 2012
    Location
    Corpus Christi, TX
    Posts
    25

    Clutch pedal feels "notchy"? Help!

    This just happened to me recently. It feels like its not as stif as it normally is. Kind of spongy. It's a lot easier to shift but it just don't feel right. I don't know if the recent cold front had anything to do with it.


    Sent from my iPhone using Tapatalk "JEV361"

  13. #27
    Registered User snakespit's Avatar
    Join Date
    Aug 2012
    Location
    Willow Grove, PA
    Posts
    27
    I had this same thing happen after about 1000 miles on my new '12. It lasted for about 3 days, and I was just getting ready to call the shop when it stopped. Has not happened since, and I've put about 2500 more miles on it. I am going to ask them to look at it when I take it in for my 7500 mile service. While my car is under warranty, I have no problem asking about any detail no matter how insignificant it may seem.
    It's sad that in this day in age a family can be torn apart by something as small as a pack of wild dogs.

    2012 OBP WRX Wagon

  14. #28
    Registered User Dzanga's Avatar
    Join Date
    Oct 2011
    Location
    phx
    Posts
    255

    Clutch pedal feels "notchy"? Help!

    Well guys after I have had mine for about a month after they changed the throw out bearing no problems. So I wouldn't be surprised if that's it. My car also did it every so often and then would go away but after about 11k it would do it more often. I suggest taking it in and have them check it out
    2012 Wrx SWP Hatch-Traded
    2013 Limited ISM Hatch -Current

  15. #29
    Registered User free2be4ever7's Avatar
    Join Date
    Nov 2011
    Location
    chicago burbs
    Posts
    262
    I Support ClubWRX
    Happy I found this thread, I have 15k on my '12. I had them check it out on my last service but no problem was found so, I'll bring it up next service. Mine is also intermittent so hopefully it acts up there.

  16. #30
    Registered User free2be4ever7's Avatar
    Join Date
    Nov 2011
    Location
    chicago burbs
    Posts
    262
    I Support ClubWRX
    So I've been doing experimenting when my clutch petal is feeling normal, and today after a 20 min normal drive I shifted into 2nd, fully let the clutch out and then accelerated until around 5k then shifted again. As I depressed the clutch to shift, I can feel the vibration already. This makes me think the problem is non clutch related. Any body else? Or are there any other experiments I can try?

+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •