damn endlink bolt - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 18 of 18

This is a discussion on damn endlink bolt within the Suspension & Wheels forums, part of the Tech & Modifying & General Repairs category; Weird. I have a Cusco rear sway bar and the stock rubber endlinks and i have never had an issue, ...

  1. #16
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    Weird. I have a Cusco rear sway bar and the stock rubber endlinks and i have never had an issue, and that includes a Time Trial class at New Hampshire International Speedway (12 turn race track).
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User
    Join Date
    Apr 2003
    Posts
    5,534
    I had the same problem with my top right endlink bolt... happened to me twice.

    I had to machine the spacers myself out of mild steel. I have helix endlinks, but I bet the bearings are the same so my spacers would work.

    I was going to make more later out of stainless steel, gimme a PM if you want


    In the meantime you can use nylon spacers, they work for a while but will eventually get crushed.

  4. #18
    GraysonSubaru's Avatar
    Join Date
    May 2005
    Location
    Knoxville, TN
    Posts
    4,686
    situation handled -- matt from vivid racing hooked me up. parts will be here wednesday.
    Quote Originally Posted by RayfieldsWRX View Post
    Hey, being the forum car ADD guy is better than being the forum OG.
    Quote Originally Posted by Mikie13 View Post
    Well nobody cares what you think, Seth

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •