power brakes+snow=NO POWER BRAKES!!!!
Results 1 to 7 of 7

This is a discussion on power brakes+snow=NO POWER BRAKES!!!! within the Suspension & Wheels forums, part of the Tech & Modifying & General Repairs category; slowing down from highway speed at the one corner i have to make to get into town i loose power ...

  1. #1
    Registered User tirerob's Avatar
    Join Date
    Nov 2012
    Location
    bug-eyeing in the Bakken
    Posts
    973

    power brakes+snow=NO POWER BRAKES!!!!

    slowing down from highway speed at the one corner i have to make to get into town i loose power boost and my brake petal goes rock hard. its done this once or twice briefly before(usually a brief off-throttle will bring it back) but this time it stayed unpowered the rest of the three miles into town. then, rolling up to the first light off throttle...i get full boost back and brakes operate normally. been fine all day today as well. thoughts? i did trigger abs on a few icy spots before i got on the highway. aaand was just reading about the abs recall. could this be related? i cant find any service records in my stack about the former owners replacing that module.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Ruh Roh's Avatar
    Join Date
    Dec 2011
    Location
    Pottstown PA
    Posts
    3,249
    Quote Originally Posted by tirerob View Post
    slowing down from highway speed at the one corner i have to make to get into town i loose power boost and my brake petal goes rock hard. its done this once or twice briefly before(usually a brief off-throttle will bring it back) but this time it stayed unpowered the rest of the three miles into town. then, rolling up to the first light off throttle...i get full boost back and brakes operate normally. been fine all day today as well. thoughts? i did trigger abs on a few icy spots before i got on the highway. aaand was just reading about the abs recall. could this be related? i cant find any service records in my stack about the former owners replacing that module.
    the service bulletin for the"ABS recall" is where the ABS kicks in very easily over a loose surface: snow, ice, leaves, dirt, rocks, etc. sounds to me like your not getting the ABS to even kick in after you triggered it...your also losing boost power? how do you know your losing boost? accelerating and on brakes at the same time???? says a brief off throttle brings it back up.. do u brake with your left foot and use the right only for gas?

  4. #3
    Registered User tirerob's Avatar
    Join Date
    Nov 2012
    Location
    bug-eyeing in the Bakken
    Posts
    973
    Yes no abs with booster loss and I switch foot on the brakes depending on clutch or coasting. The brake petal went rock hard but the brakes still work. Just gotta push Hard....no power boost. And ya my abs is twitchy but it works Ok. Our roads are all just about glare ice right now anyway.

  5. #4
    Registered User oguitar's Avatar
    Join Date
    Nov 2009
    Location
    Albuquerque, New Mexico, United States
    Posts
    1,021
    How old is the brake fluid? Could be freezing up due to it being really old. Just a guess.
    Life is like riding a bicycle in order to keep your balance you must keep moving.

  6. #5
    Registered User Ingo's Avatar
    Join Date
    Mar 2012
    Location
    Colorado Springs, CO
    Posts
    1,110
    I suspect a vacuum leak or the booster itself...
    You can't have everything - where would you put it?

  7. #6
    Registered User tirerob's Avatar
    Join Date
    Nov 2012
    Location
    bug-eyeing in the Bakken
    Posts
    973
    does the wrx have a external one way check valve on the booster's vacuum line off the manifold? it looked like it was ran directly into the intake to me. i can see the tell tale sign of a formally leaking master cylinder(replaced just before i purchased the car.) i might pull that back(master cylinder) and check the seal inside the booster making sure its not damaged from brake fluid.

  8. #7
    Registered User Ingo's Avatar
    Join Date
    Mar 2012
    Location
    Colorado Springs, CO
    Posts
    1,110
    Sorry, that gets too specific for me, I can look up the gen3 stuff, but that's it for me. Mine is an '09.
    You can't have everything - where would you put it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •