06 STi Plastic Motor Mounts-be careful!! - Page 6
Page 6 of 6 FirstFirst 123456
Results 76 to 78 of 78

This is a discussion on 06 STi Plastic Motor Mounts-be careful!! within the STi Transmission/Drivetrain forums, part of the STi Technical Forum category; after reading this thread (and a couple of others) and seeing them abandon liquid filled mounts and then re-introducing them, ...

  1. #76
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,344
    I Support ClubWRX
    after reading this thread (and a couple of others) and seeing them abandon liquid filled mounts and then re-introducing them, makes me guess these are a new revision- hopefully better than the first
    "Simplify and add lightness." - Colin Chapman

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #77
    Registered User
    Join Date
    Apr 2010
    Posts
    1

    07 STi broken mount

    Hey guys, new to the forum, caught this link searching on IWSTi... I have an 07 STi and I recently broke my driver side motor mount launching. Am I correct in assuming that the early 06 STi was the only model that came with the water/plastic mounts and my car has rubber mounts? Will I still be able to warrantee my mounts if they are not the water/plastic?

    I am also curious what you guys said to the dealer when you say you "told them how you broke the mounts." Did you just say yeah I launched it hard and it cracked? I don't feel like Subaru would be very helpful in that scenario...

    Thanks in advance for all your help,
    Brian
    Last edited by illegalSTi18; 04-14-2010 at 03:31 PM.

  4. #78
    Registered User
    Join Date
    Nov 2012
    Posts
    20
    was this ever corrected? did subaru ever go back to solid mounts on the newer models?

Page 6 of 6 FirstFirst 123456

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •