06 STi Plastic Motor Mounts-be careful!! - Page 2
Page 2 of 6 FirstFirst 123456 LastLast
Results 16 to 30 of 78

This is a discussion on 06 STi Plastic Motor Mounts-be careful!! within the STi Transmission/Drivetrain forums, part of the STi Technical Forum category; I'm telling you, I went into my dealership here in Ohio and told them I broke them launching the car ...

  1. #16
    Registered User
    Join Date
    Mar 2006
    Posts
    6

    new mounts

    I'm telling you, I went into my dealership here in Ohio and told them I broke them launching the car and explained the difference from '04-'05 to the '06 mounts. They happily covered the repair under warranty with no questions asked. They even went the extra mile and installed my GroupN mounts for a little extra labor charge.

    GroupN mounts work just peachy. No motor rocking. I don't notice any extra cabin noise and they LAUNCH like HELL. woohoo!!!!!!!! Repeated hard launches have done nothing to them. The stock one was in 3 pieces when they took it out.

    Quote Originally Posted by YBNormal07
    Oh....they warrentied the broke mount, but the warranty only covered replacement with the same platic POS right? Ok..that is better news. Will they at least install them for you?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User Wyatt's Avatar
    Join Date
    May 2006
    Location
    Boise Idaho
    Posts
    28
    Look familiar?
    Attached Thumbnails Attached Thumbnails DSC00322.JPG  

  4. #18
    Registered User
    Join Date
    Mar 2006
    Posts
    6

    nice

    That's pretty scary. I am hard pressed to tell the difference between your break and mine. If you haven't clicked on my link above, check it out. These new mounts are clearly a bad design. When you take yours out, you will be amazed at what a plastic piece of $h!t it is.

  5. #19
    Registered User Wyatt's Avatar
    Join Date
    May 2006
    Location
    Boise Idaho
    Posts
    28
    Got my Group-N motor mounts overnight thanks to Gruppe-S, but now the bastards at Subaru won't work on my car until Friday. It's going to be an unbearable 72 hours without being able to get on the gas

  6. #20
    Moderator YBNormal07's Avatar
    Join Date
    Jul 2003
    Location
    PA
    Posts
    6,244
    I Support ClubWRX
    Quote Originally Posted by Wyatt
    Got my Group-N motor mounts overnight thanks to Gruppe-S, but now the bastards at Subaru won't work on my car until Friday. It's going to be an unbearable 72 hours without being able to get on the gas
    c'mon...havene't you ever heard of the coat hanger mod?
    tEh PriUs=teH faSTah!@@!
    08 Audi S5 Black Diamond edition
    SOLD: 05 SWP Legacy GT Limited 5MT, 13.3ish@105 (stage 2) crappy stock clutch
    SOLD: 04 MPS/SW WRX Sti. 12.971 @ 103.97 (stock)
    278 AWHP/283 AWT, Catback exhaust
    306 AWHP/341 AWT, Stage 2
    (Scott) Moderator-STi, Drag Racing, Car Purchasing, and Tutorial Forums

  7. #21
    Registered User Wyatt's Avatar
    Join Date
    May 2006
    Location
    Boise Idaho
    Posts
    28
    Man these Group-N mounts are heavy, ugly bastards. I swear each one weighs 5 lbs.
    Attached Thumbnails Attached Thumbnails DSC00324.jpg  

  8. #22
    Moderator YBNormal07's Avatar
    Join Date
    Jul 2003
    Location
    PA
    Posts
    6,244
    I Support ClubWRX
    You should see the Group N tranny mount. Wadda hunk!
    tEh PriUs=teH faSTah!@@!
    08 Audi S5 Black Diamond edition
    SOLD: 05 SWP Legacy GT Limited 5MT, 13.3ish@105 (stage 2) crappy stock clutch
    SOLD: 04 MPS/SW WRX Sti. 12.971 @ 103.97 (stock)
    278 AWHP/283 AWT, Catback exhaust
    306 AWHP/341 AWT, Stage 2
    (Scott) Moderator-STi, Drag Racing, Car Purchasing, and Tutorial Forums

  9. #23
    Registered User Wyatt's Avatar
    Join Date
    May 2006
    Location
    Boise Idaho
    Posts
    28
    Ok, now the dealership just called me and told me the parts I gave them (the Group-N mounts) are designed for the 04-05 model ONLY.

    This is BS right? I thought the mounts hadn't changed since '02?

    I told them to just try to fit them anyways

  10. #24
    Banned
    Join Date
    May 2004
    Location
    San jose California
    Posts
    76
    hey man
    when did u buy ur car?

    cuz i jus got a new sti
    and i have the 04 05 mounts on them
    and changed them to cusco mounts
    but yea

    new sti
    i bought it on march 28 2006
    and looked under the car i have 04 05 mounts
    tranny and motor mounts

    so anyone else having this on the new purchased sti?

  11. #25
    Registered User Wyatt's Avatar
    Join Date
    May 2006
    Location
    Boise Idaho
    Posts
    28
    I bought mine in December.

  12. #26
    Registered User Wyatt's Avatar
    Join Date
    May 2006
    Location
    Boise Idaho
    Posts
    28
    Here's one destroyed PLASTIC motor mount:
    Attached Thumbnails Attached Thumbnails DSC00326.jpg  

  13. #27
    Registered User Wyatt's Avatar
    Join Date
    May 2006
    Location
    Boise Idaho
    Posts
    28
    Oh and also, for the record: the Group-N motor mounts fit just fine. The dealership was just confused.

  14. #28
    Registered User uncle lewie wrx's Avatar
    Join Date
    Oct 2004
    Posts
    4,936
    Quote Originally Posted by DownSTi
    hey man
    when did u buy ur car?

    cuz i jus got a new sti
    and i have the 04 05 mounts on them
    and changed them to cusco mounts
    but yea

    new sti
    i bought it on march 28 2006
    and looked under the car i have 04 05 mounts
    tranny and motor mounts

    so anyone else having this on the new purchased sti?
    Yes sir, you are correct. I checked today. Refer to this thread, on IWSTI. I bought my car three weeks ago. http://www.iwsti.com/forums/showthread.php?t=51875
    06 Aspen White STi w/ Gold BBS's

  15. #29
    Registered User Wyatt's Avatar
    Join Date
    May 2006
    Location
    Boise Idaho
    Posts
    28
    Let me get this straight. Am I to understand that Subaru started shipping '06 STis with the plastic mounts (that I broke before my car had 5,000 miles on it), and now they are shipping them with DIFFERENT mounts from the factory?!

    My Subaru dealership told me they wouldn't even warranty the labor to put in the Group-N mounts, so I just paid $170 to have it done today.

    If it's true that Subaru is now shipping with different mounts, I'm going to get my F'N money back!

  16. #30
    Registered User uncle lewie wrx's Avatar
    Join Date
    Oct 2004
    Posts
    4,936
    Quote Originally Posted by Wyatt
    Let me get this straight. Am I to understand that Subaru started shipping '06 STis with the plastic mounts (that I broke before my car had 5,000 miles on it), and now they are shipping them with DIFFERENT mounts from the factory?!

    My Subaru dealership told me they wouldn't even warranty the labor to put in the Group-N mounts, so I just paid $170 to have it done today.

    If it's true that Subaru is now shipping with different mounts, I'm going to get my F'N money back!
    Your dealer is a bunch of crooks. Yours broke? And they didnt warranty it?? That 100% should be warrantied. The cases Ive heard in the local dealerships that have seen broken mounts, have all fixed em with the 04-05 mounts, under warranty. Id go back to your dealer and raise hell. HOWEVER, you cant make them put in the group N mounts, only the 04-05 ones (they might be the same tho). Id go back to your dealer and say, "Hey guys, SOA wont be to happy to hear what you did to me."
    Yeh, it appears to be that SOA changed the mounts mid production on the 06.
    06 Aspen White STi w/ Gold BBS's

Page 2 of 6 FirstFirst 123456 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •