04 STi ECU reflash confirmed (ping fix)
+ Reply to Thread
Page 1 of 4 1234 LastLast
Results 1 to 15 of 47

This is a discussion on 04 STi ECU reflash confirmed (ping fix) within the STi Technical Forum forums, part of the Tech & Modifying & General Repairs category; http://forums.nasioc.com/forums/show...hreadid=394329 This was posted over on nasioc and I am passing on the info: I just learned from my regional ...

  1. #1
    Registered User
    Join Date
    Mar 2003
    Location
    Atlanta
    Posts
    29

    04 STi ECU reflash confirmed (ping fix)

    http://forums.nasioc.com/forums/show...hreadid=394329

    This was posted over on nasioc and I am passing on the info:

    I just learned from my regional SOA rep that Subaru of America has just received their updated ECM flash from SoJ for the USDM STi to combat the detonation problem.

    Customers will need to leave their car with the dealer while their ECMs are sent to Subaru for reprogramming. There is an expected 4-6 day turnaround time.

    As soon as more flash units become available from Subaru, this will be a dealership-level flash service.

    Let your dealer know IF you are experiencing detonation (NOT ALL CARS EXHIBIT IT!), and they will help you resolve the issue after testing and verification. If they aren't already up to speed on the issue, have them contact their regional rep for more information.

    It may take some time for information to disseminate and to arrange scheduling through your dealer. PLEASE BE PATIENT through this process, this is not a recall so you will have to go through the full dealership testing, work order, and reporting process. There is an order in which this process must happen, please give your local dealerships the benefit of the doubt on this and allow the SOA reporting and resolution (flash) process to work as it should.

    Enjoy!

    -Jason Porter
    Subaru of Gwinnett-Atlanta
    Last edited by YBNormal07; 02-13-2006 at 10:31 AM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Mar 2003
    Location
    Atlanta
    Posts
    29
    I got my car back today after doing the reflash. No problems, no more pings, and it still feels like it has the same amount of power. So I definately recommend the fix.

    Dan

  4. #3
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    Bump for you guys wondering about this.
    03 Cobra
    566whp/515wtq

    Pics
    & Dyno
    Pics

  5. #4
    Registered User rebelzx's Avatar
    Join Date
    Jun 2003
    Posts
    26
    Are they performing this fix on all STI's? Or this only on a case-by-case basis? So if I was to buy an STI now, would it already have the re-flash?
    Evo-NY #026
    363 whp 377 torque
    12.2 @ 110.8

  6. #5
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    Good question. You should contact a local dealer and ask.

  7. #6
    Registered User
    Join Date
    Jul 2003
    Location
    Sacramento, CA
    Posts
    11
    I got my car back today after doing the reflash. No problems, no more pings, and it still feels like it has the same amount of power. So I definately recommend the fix.

    Dan
    ... That's good to hear Dan, thanks for the update. I am taking my STI next Monday for re-flashing. Even w/ 91 fuel & 104 Octane Booster, I still get knocking
    Farewell my Darkside 2000 Honda Accord EXV6. Now a proud owner of a 2004 Subaru Impreza WRX STi!

  8. #7
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    Vader? What's up man! So you finally got rid of that Accord, eh?

  9. #8
    Registered User
    Join Date
    Jul 2003
    Location
    Sacramento, CA
    Posts
    11

    Cool Wuz up AjIsDope?!

    Vader? What's up man! So you finally got rid of that Accord, eh?
    ... sure did my friend. My V6 is history, but I am still a big supporter of the V6p site. Either way, it's good to hear from you. Take care.
    Farewell my Darkside 2000 Honda Accord EXV6. Now a proud owner of a 2004 Subaru Impreza WRX STi!

  10. #9
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    So am I. I am still a mod over there and continue to lurk around the site. Welcome to the club!

    <thread jack off>

  11. #10
    Registered User STi_Andy's Avatar
    Join Date
    Jun 2003
    Location
    Montreal, Canada
    Posts
    46
    i dont understand why there's only pinging on certain STis and not others. is it octane related?
    because i run on 94 and have no detonation but there are ot her stis running on 94 too and they detonate.
    i'm confused.
    can anyone please explain?
    "somehow the car feels faster when u drive it"

  12. #11
    Registered User
    Join Date
    Aug 2003
    Posts
    177
    Got my car back yesterday, it does feel stronger and no more detonation. Took 5 days (4 nights) to send out the ECU, reflash, and return ECU.

    I highly recommend this fix as it is now listed as an official "recall" notice. It is not just a matter of pulling timing. Besides anyone interested in doing the XEDE piggy back ECU will need to get this fix done first as the "bug" in the existing ECU could cause problems.

  13. #12
    Registered User
    Join Date
    Jul 2003
    Location
    Sacramento, CA
    Posts
    11
    Yeah, I got my reflash done last week. It took 3 days altogether... NO more major pinging sound....

    BUT I still notice a slight pinging when it's hot, AC is blasting, and when I am accelerating hard....

    I called my Subby rep and he said that this would be normal under such conditions, and that I should starting using better fuel such as Shell or Chevron.......

    Either way, its hardly pings at all... plus I feel that my powerband is still the same. Still hauling azz...
    Farewell my Darkside 2000 Honda Accord EXV6. Now a proud owner of a 2004 Subaru Impreza WRX STi!

  14. #13
    Registered User
    Join Date
    Sep 2003
    Location
    maine
    Posts
    44
    I have the pinging problem also, its especially bad 1st thing in the morning. I'm hoping to bring the car in for re-flash tomorrow.
    My question is, would that be the same problem that would cause the exhaust to stink? When I take the car up to 100mph or so I can smell what smells like the catalytic converter.
    Its gonna be hard to let the car for for 4-6 days
    the re-flash won't cost me anything right?

  15. #14
    Registered User
    Join Date
    Jul 2003
    Location
    Sacramento, CA
    Posts
    11

    No cost.

    If your lucky, it should only take 3 days altogether.... but NO, they should not charge you a dime, plus you should be getting a rental for free. Good luck.
    Farewell my Darkside 2000 Honda Accord EXV6. Now a proud owner of a 2004 Subaru Impreza WRX STi!

  16. #15
    Registered User
    Join Date
    Sep 2003
    Location
    maine
    Posts
    44
    well I went to the dealership today and they said they hadn't heard anything about sti's pinging. I asked if they would send my ecu for a flash and they said no its considered a mod and wouldn't do it. The only thing I can do is leave the car there for them to check it out but they probably wouldn't do anything because they were acting like pinging is normal. What should I do now? thats the only subaru dealership in the state. I tried to tell him how many other sti owners had the exact same problem and the flash took care of it and he acted like he didn't want to hear it, not to mention one of the guys was almost laughing when I went there. I wanted to sock him right in the face
    is there some kind of documentation or something I can print up to bring to these guys?

+ Reply to Thread
Page 1 of 4 1234 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •