2007 Sti Messed Up
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 24

This is a discussion on 2007 Sti Messed Up within the STi Technical Forum forums, part of the Tech & Modifying & General Repairs category; My 2007 STI hit 5,000 miles. Now all of a sudden the boost is lost. It is still spooling but ...

  1. #1
    Registered User nothingclub's Avatar
    Join Date
    Dec 2006
    Location
    nj
    Posts
    16

    2007 Sti Messed Up

    My 2007 STI hit 5,000 miles. Now all of a sudden the boost is lost. It is still spooling but it is lost to god knows where. Everything is fluttering when I open throttle. Itll buck and do nothing when I floor it until like reallllly late in the RPM band. I am guessing this has to do with that 2007 REFLASH recall everyones talking about.... The only thing is it hasnt happened until the second i hit 5,000 miles. Anyone else have an 07 STI PM me please. This is stupid. I dont beat on my car. Clutch is fine. Oil is good. I dont know

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2

    Admin - Scooby Hooligan

    Weasel 555's Avatar
    Join Date
    Jul 2002
    Location
    UK,NY,AK,FL
    Posts
    23,158
    I Support ClubWRX
    go back to the dealer
    ScoobyDMC #000,HawkEyeAlliance#000,Blobeye Syndicate #000, SQC-NY #009, "Dragon Slayer"
    "All We'll Drive"

    I <3 boobies: rallyarmor/keepabreast/mud flaps limited edition

  4. #3
    Registered User LilJohn's Avatar
    Join Date
    Oct 2006
    Location
    Orange County California
    Posts
    167
    this is a dumb question but is the check engine light on?
    Pics of my STi
    2004 WRX STi (WR Blue)
    Organic Racing Clutch
    Turboback Exhaust + Up-Pipe
    Stage 2 Ecu Reflash @ 18 psi

  5. #4
    Registered User nothingclub's Avatar
    Join Date
    Dec 2006
    Location
    nj
    Posts
    16

    Nope

    nope... everything looks as it would normally. Even boost gauge functions correctly. Ill keep you guys posted as to what happens.

  6. #5
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    any mods ?
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  7. #6
    Registered User nothingclub's Avatar
    Join Date
    Dec 2006
    Location
    nj
    Posts
    16

    nope

    nope no mods --- its sittin at the dealers right now. just dropped it off. they better not give me shiit for this...

  8. #7
    Registered User blahblah's Avatar
    Join Date
    Sep 2003
    Location
    Chi-cago
    Posts
    816
    I'm interested to see what happens. keep us posted
    282 AWHP...267 lb-ft torque.
    2005 WRB WRX Sedan

    "he's a domestic fan with a hunger for rice"

  9. #8
    Registered User
    Join Date
    Jan 2007
    Location
    Delaware
    Posts
    41
    Bump.
    Varsity Powder in the 04' Audi A4

  10. #9
    Registered User Jje121's Avatar
    Join Date
    Jan 2005
    Location
    Fitchburg, ma
    Posts
    0
    subscribes
    New England F4
    Bugeye Mafia
    2004 GMC Sierra 1500
    03 Subaru WRX (SOLD)
    01 CBR 929 (SOLD)
    Quote Originally Posted by blarg
    nothing funny about stubble on the man-marbles.

  11. #10
    Registered User cavallino333's Avatar
    Join Date
    Feb 2005
    Location
    Campbell CA
    Posts
    11,850
    Quote Originally Posted by Weasel 555 View Post
    go back to the dealer
    +1
    FORZA FERRARI
    BLOBEYE SYNDICATE (retired) #13
    Quote Originally Posted by Integra96 View Post
    One day I hope to buy a car that is lubricated exclusively by pure manatee oil.

  12. #11
    Registered User 96accord's Avatar
    Join Date
    Mar 2007
    Location
    Baltimore, Maryland
    Posts
    6,127
    any updates???

    get your car back yet?

  13. #12
    Registered User orvtech's Avatar
    Join Date
    Nov 2005
    Location
    Miami
    Posts
    1,077
    check the little hose that goes from the throttle body to the IC, just in case.

  14. #13
    Registered User nothingclub's Avatar
    Join Date
    Dec 2006
    Location
    nj
    Posts
    16

    update

    okay guys so heres whats been going on...

    Brought my car to the dealer... They checked for physical boost leaks --nothing found. They then, reflashed the ecu. Clearing memory. AND BAM... there it was. Working mint, perfect, 14.5 lbs. Then after a few times of restarting the car and putting some miles on it... the computer went right back to boosting at around 6 lbs.

    2nd time at the dealer... Did the same thing, hoping the first time wasnt a fluke stupid dealers.. So they reflash it and once again works perfect. I then make the trip home. Drive for a bit on and off. And back to the 6 lb problem.

    NOW -- I am in contact with techs from subaru of america. I think wedsnday I am getting a whole new ECU. Ill keep posting. If ANYONE ANYONE has the same problem with your 07 STI please contact me. This is absolutely ridiculous. And the sad thing is its almost impossible to detect the exact problem because no check engine lights are going off.

  15. #14
    Registered User orvtech's Avatar
    Join Date
    Nov 2005
    Location
    Miami
    Posts
    1,077
    hum... i think it is time for me to get a boost gauge

  16. #15
    Moderator
    Join Date
    Jul 2003
    Location
    Maryland
    Posts
    11,098
    I Support ClubWRX
    Sounds like it might be running off of wastegate pressure.
    0-60 faster then your first sexual experience.
    "You've come far, and though you're far from the end
    You don't mind where you are, cause you know where you've been"

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •