Vacuum Line issues 05 STI
Results 1 to 13 of 13

This is a discussion on Vacuum Line issues 05 STI within the STi Technical Forum forums, part of the Tech & Modifying & General Repairs category; I have an 05 STI that I bought to replace my WRX. The problem is that the kid I bought ...

  1. #1
    Registered User 05wrxtmp's Avatar
    Join Date
    Jan 2012
    Location
    Chesapeake VA
    Posts
    15

    Vacuum Line issues 05 STI

    I have an 05 STI that I bought to replace my WRX. The problem is that the kid I bought it from did some janky s#!t with the hosing on top of the engine. There is some big sensor with two male ends for some hoses and it was not connected to anything. Not only was that not connected, but there are lines just chilling not connected to anything. I have been looking through the different forums and the best I can gather is that the sensor is a crank case pressure sensor. I'm probably wrong, but I can't figure it out. It wouldn't idol but then connected it to some of the random lines, and now it idols, but it blows white smoke over 10psi. Something is clearly wrong and I was wondering if anyone with more information than me can help me out. Any help would be appreciated

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,722
    I Support ClubWRX
    Picture(s) would help...
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  4. #3
    Registered User wreckingball man's Avatar
    Join Date
    Jul 2012
    Location
    Rocky Top
    Posts
    2,276
    ^Yep, we'll be able to help you with pics. And for your own research while you wait on us, google images.

  5. #4
    Registered User 05wrxtmp's Avatar
    Join Date
    Jan 2012
    Location
    Chesapeake VA
    Posts
    15
    Click image for larger version. 

Name:	IMAG0940.jpg 
Views:	19 
Size:	55.8 KB 
ID:	123098

    Click image for larger version. 

Name:	IMAG0941.jpg 
Views:	19 
Size:	59.3 KB 
ID:	123106

    Click image for larger version. 

Name:	IMAG0942.jpg 
Views:	19 
Size:	111.3 KB 
ID:	123114

    Click image for larger version. 

Name:	IMAG0943.jpg 
Views:	19 
Size:	62.9 KB 
ID:	123122

    Click image for larger version. 

Name:	IMAG0944.jpg 
Views:	19 
Size:	92.5 KB 
ID:	123130

    Click image for larger version. 

Name:	IMAG0945.jpg 
Views:	19 
Size:	84.1 KB 
ID:	123138

    Click image for larger version. 

Name:	IMAG0946.jpg 
Views:	19 
Size:	75.5 KB 
ID:	123146

    Click image for larger version. 

Name:	IMAG0947.jpg 
Views:	19 
Size:	80.4 KB 
ID:	123154

    Click image for larger version. 

Name:	IMAG0948.jpg 
Views:	18 
Size:	62.5 KB 
ID:	123162

    Click image for larger version. 

Name:	IMAG0949.jpg 
Views:	18 
Size:	74.0 KB 
ID:	123170

    The white sensor is not hooked up correctly but followed it back to another T and I took off the little cap you can see and there was some coolant in it. So now I'm thinking head gasket but the lines are still messed up too. the line I'm pointing at with the wrench in the one photo is the line that eventually goes into that white sensor and also the one that had the coolant in it (a very small amount). I know this is really vague and probably doesn't make seance, but I could really use some help

  6. #5
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,770
    Good lord. Congrats...you just bought a car some kid ruined. Looks like he removed a boost gauge, and didn't bother actually putting it back the way it should be. Also has an EWG that looks like it's not connected, which may explain lines that aren't going to where they should be.

    Why'd you buy a car that a kid did Janky **** to???
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning
    "If I have 10 ice cubes and you have 11 giraffes, how many pancakes can fit on the roof? Purple, because aliens donít wear hats" -Ying

  7. #6
    Registered User 05wrxtmp's Avatar
    Join Date
    Jan 2012
    Location
    Chesapeake VA
    Posts
    15
    good price and it isn't my primary car. I'm having trouble finding anything that shows me what everything should look like, were everything goes to and what the different lines do. I'm not to clear on the functions of the different lines or I could probably figure it out myself

  8. #7
    zax
    zax is offline
    Į\_(ツ)_/Į zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    12,874
    I Support ClubWRX I Support ClubWRX
    Uh, that's a rotated turbo setup.

    That car is FAR from stock. No diagram is going to help you.
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  9. #8
    Registered User 05wrxtmp's Avatar
    Join Date
    Jan 2012
    Location
    Chesapeake VA
    Posts
    15
    That is the problem. I can't find anything that would help me out because of what is done to it. I suppose I should have started with the fact that it is a rotated set up.

  10. #9
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,770
    Quote Originally Posted by zax View Post
    Uh, that's a rotated turbo setup.

    That car is FAR from stock. No diagram is going to help you.
    Holy ****...it is rotated

    Good thing that isn't supposed to be your Daily Driver...
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning
    "If I have 10 ice cubes and you have 11 giraffes, how many pancakes can fit on the roof? Purple, because aliens donít wear hats" -Ying

  11. #10
    Registered User wreckingball man's Avatar
    Join Date
    Jul 2012
    Location
    Rocky Top
    Posts
    2,276
    Just focus on one thing at a time and it will cut down on the mass of hoses in your face...giggity:

    -Looks like the stock BPV
    -Looks like the stock 2 port EBCS in the corner of pic 3, and the EWG with that. Do you have an MBC?
    -The engine breather system

    It's an 05 STi, so i'm not at all familiar with what's in the pictures, not to mention it's rotated. If it were an 02-03 I could tell you right off the bat because I've replaced most all of those systems on my car. I would have a tuning shop that knows subarus look at it. It would be a lot easier in person as it looks pretty extensive...

    Do you have any way to contact the tuner who worked on this?

  12. #11
    Registered User 05wrxtmp's Avatar
    Join Date
    Jan 2012
    Location
    Chesapeake VA
    Posts
    15
    Yeah, it was the AMS shop car and I called them, but they don't have anything on it anymore. I had P&L out of Chicago tune it when I got it and they didn't even notice that the white sensor thing wasn't hooked up and that there were hoses going to no where. They just threw it on the dyno and as it was dying as they were pulling it out of the shop, told me to get used to that. Rather pissed that I spent $550 to have a built motor tuned with MASSIVE vacuum issues. I know I'm probably stupid for this but I don't know what EBCS, EWG,or MBC stand for.

    Here is a list of the Mods I know of

    Engine:
    * Eagle rods
    * Supertech pistons
    * Supertech dual springs, Ti retainers, and alloy seats
    * TGV Delete
    * Brand new timing components
    * Cusco motor mounts
    * Koyo radiator
    * AMS Small battery kit
    * AMS MBC
    * Koyo Radiator
    * Open Source flash
    * Choice of tune at time of sale: 93oct (current) or C16
    * Prototype AMS turbo kit with;
    * Garrett GT30R .82AR
    * Tial 44mm Wastegate
    * Custom Cold Air Intake
    * Custom Downpipe and Uppipe

    Transmission:
    * Exedy Twin disc clutch

    Interior
    * Autometer CF gauge cups (2)
    * AEM UEGO wideband
    * Autometer boost gauge

    Fuel:
    * Walbro 255lph in-tank pump
    * DeatschWerks 850cc injectors

    Exhaust:
    * Prototype AMS turbo back
    * Vibrant muffler with 5" tip

    Suspension:
    * Whiteline Max-C camber plates

    Brakes
    * Giro Disc rotors (Front) - 10lbs less than stock.
    * Performance Friction Brake Pads (F&R)

  13. #12
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,770
    EBCS = Electronic Boost Control Solenoid

    MBC = Manual Boost Controller

    EWG = External Waste Gate


    Weird that P&L didn't take the time to look it over and make sure everything was good...unless you didn't ask them to do it. They would assume you're coming in with a car that's ready to go. They are supposed to be a good shop the last I heard.

    You need to have someone look it over with a fine tooth comb. It's got a lot more going on than what we can just tell with some pictures.
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning
    "If I have 10 ice cubes and you have 11 giraffes, how many pancakes can fit on the roof? Purple, because aliens donít wear hats" -Ying

  14. #13
    Registered User 05wrxtmp's Avatar
    Join Date
    Jan 2012
    Location
    Chesapeake VA
    Posts
    15
    the manual boost controller isn't hooked up. i just haven't taken it off. i told P&L that i was having MAJOR idol issues before i came in. They are normally good and i took my WRX there all the time. I was wondering if anyone else with a rotated set up could even just post a few pictures to give me an idea

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •