broke down on the highway HELP!!!
Results 1 to 6 of 6

This is a discussion on broke down on the highway HELP!!! within the STi Technical Forum forums, part of the Tech & Modifying & General Repairs category; Was passing a car on the highway, hit full boost and then I lost all power and backfired every time ...

  1. #1
    Registered User
    Join Date
    Feb 2012
    Location
    UK
    Posts
    7

    broke down on the highway HELP!!!

    Was passing a car on the highway, hit full boost and then I lost all power and backfired every time I tried to step on the gas. Got to the shoulder and she died, I checked all the vaccum lines and intercooler piping and everything was good. I tried to start it, it will turn over but won't start. Any ideas or advice will be great. Thanks.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    13,156
    I Support ClubWRX I Support ClubWRX
    Any CELs? What year/model car and what mods?
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  4. #3
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,985
    Somethin done esploded!


    Need Zax's questions answer to begin any troubleshooting
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning

  5. #4
    Registered User
    Join Date
    Feb 2012
    Location
    UK
    Posts
    7
    its a 96 wrx with 3in exost fmic and a boost controler, and nope no CELs

  6. #5
    Registered User
    Join Date
    Feb 2012
    Location
    UK
    Posts
    7
    Quote Originally Posted by Mikie13 View Post
    Somethin done esploded!


    Need Zax's questions answer to begin any troubleshooting
    Crap I hope nuthing did

  7. #6
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,985
    Well for one, are you running any kind of engine management? Tuned for your mods?

    Do you even have a downpipe?
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan
    Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •