Installed a VF34 today...
Page 1 of 4 1234 LastLast
Results 1 to 15 of 55

This is a discussion on Installed a VF34 today... within the STi Engine Performance forums, part of the STi Technical Forum category; Well this is definitly one of those "for the hell of it" mods. Im only did this since I was ...

  1. #1
    Registered User Invisiguard's Avatar
    Join Date
    Sep 2003
    Location
    SF Bay Area
    Posts
    472

    Installed a VF34 today...

    Well this is definitly one of those "for the hell of it" mods. Im only did this since I was installing headers(thanks Dan!) and Perrin inlet today, and I knew a guy selling a brand new VF34 that once I sell my deadbolt'd VF39 will hopefully be a free swap.

    No mention has been made of using a VF34 since everyone just assumed use a VF22 being the biggest VF, but the 34 is actually bigger than our 39(P18 turbine vs. P17 and 30/34 has larger compressor as well) and with its more efficient design I should avoid the lag STi guys are still getting with the 22s, also since WRX guys use the 30/34 with our size injectors I should be just fine at stock boost levels. I'll dyno this setup in a few days, Im not looking for tons of extra power, just want what all of us want, a turbo that can hold boost to redline without going with bigger injectors and engine managment, I'll post results!
    Invisiguard@sbcglobal.net

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Invisiguard's Avatar
    Join Date
    Sep 2003
    Location
    SF Bay Area
    Posts
    472
    Heres a size comparison, you can clearly see even from this pic the 30/34s larger compressor, its even easier to tell up close
    Attached Thumbnails Attached Thumbnails vf.jpg  
    Invisiguard@sbcglobal.net

  4. #3
    Registered User Invisiguard's Avatar
    Join Date
    Sep 2003
    Location
    SF Bay Area
    Posts
    472
    before...
    Attached Thumbnails Attached Thumbnails picture 287.jpg  
    Invisiguard@sbcglobal.net

  5. #4
    Registered User
    Join Date
    Nov 2003
    Location
    so. CAL
    Posts
    42

    Bout those headers!!

    Dont forget You more than likely will have to Either bend or cut the metal that runs paralell just in front of the headers, as my headers rubbed and it needed a little trimming....

  6. #5
    Registered User Invisiguard's Avatar
    Join Date
    Sep 2003
    Location
    SF Bay Area
    Posts
    472

    Re: Bout those headers!!

    Originally posted by myloSTI
    Dont forget You more than likely will have to Either bend or cut the metal that runs paralell just in front of the headers, as my headers rubbed and it needed a little trimming....
    WHERE WERE YOU TWO DAYS AGO!!!

    Got on the road and immeditaly heard a KNOCK KNOCK KNOCK every time I got it up over 5K, I swore I threw a rod!

    Just climbed under there today and found the "knock" was the headers hitting the Xmember, ate through the wrap pretty good too

    oh well, on better news, this turbo feels GREAT! Stretches out the RPMS to redline no prob and the most surprising part of all, cant really feel any extra lag!

    I expected a bit at least with a bit larger turbo + headers, but honestly if I wasnt actually trying hard to notice it, I would swear it spools the same as it did 2 days ago, excepts with WAY more pull they really should have used this turbo on the car in the first place
    Invisiguard@sbcglobal.net

  7. #6
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    Sweet. Can't wait until I upgrade....
    03 Cobra
    566whp/515wtq

    Pics
    & Dyno
    Pics

  8. #7
    Registered User dizastical's Avatar
    Join Date
    Jul 2003
    Location
    Maine
    Posts
    639
    Did your headers smoke when you first started the car due to the header wrap . My car had alot of smoke and it was all coming from the headers . Is that normal ?

    OH YA ! You stole my idea ................ remember this pic I posted ?
    Attached Thumbnails Attached Thumbnails pic 1.jpg  
    2004 STI ----- 11.66 @ 125.66 w/ 1.9 60' ----- 537HP/487TQ ----- 93 Octane/Water Injection
    WWW.F1DYNO.COM

  9. #8
    Registered User Invisiguard's Avatar
    Join Date
    Sep 2003
    Location
    SF Bay Area
    Posts
    472
    Originally posted by dizastical
    Did your headers smoke when you first started the car due to the header wrap . My car had alot of smoke and it was all coming from the headers . Is that normal ?

    OH YA ! You stole my idea ................ remember this pic I posted ?
    hey that looks familiar!

    yeah they smoked forever! didnt help that Im sure a ton of coolant spilled into the wrap that had to burn off
    Invisiguard@sbcglobal.net

  10. #9
    Registered User dizastical's Avatar
    Join Date
    Jul 2003
    Location
    Maine
    Posts
    639
    Same here ! Me and coolant do not get alone very well at all ! I have spilled ALOT ! Thanx for the reply . Dave
    2004 STI ----- 11.66 @ 125.66 w/ 1.9 60' ----- 537HP/487TQ ----- 93 Octane/Water Injection
    WWW.F1DYNO.COM

  11. #10
    Registered User
    Join Date
    Nov 2003
    Posts
    292
    guys the piece goin into the turbothats black is that stock?

  12. #11
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    Originally posted by NORCAL STI
    guys the piece goin into the turbothats black is that stock?
    No. That is a turbo inlet hose, made by Perrin, Samco, etc.

  13. #12
    Registered User
    Join Date
    Oct 2003
    Location
    TX
    Posts
    70

    Re: Installed a VF34 today...

    Originally posted by Invisiguard
    I'll dyno this setup in a few days, Im not looking for tons of extra power, just want what all of us want, a turbo that can hold boost to redline without going with bigger injectors and engine managment, I'll post results!
    So you're not running ANY EM at all? Just the turbo swap straight up? Sounds interesting.

  14. #13
    Registered User Invisiguard's Avatar
    Join Date
    Sep 2003
    Location
    SF Bay Area
    Posts
    472

    Re: Re: Installed a VF34 today...

    Originally posted by nathansvt
    So you're not running ANY EM at all? Just the turbo swap straight up? Sounds interesting.
    yep, stock injectors and ECU, I have a bigger fuel pump in there but not specifically for this setup, Im quite confident the injectors would max out before the stock fuel pump. Right now Im runing stock boost until I get it on a dyno and see what my IDCs are looking like, if they are not too high the turbo should make power out to 17 psi no prob.
    Invisiguard@sbcglobal.net

  15. #14
    Registered User
    Join Date
    Nov 2003
    Location
    so. CAL
    Posts
    42

    VF34 ?

    did you need to port your new turbo?

  16. #15
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    This is pretty interesting. I might have to try this myself with either that turbo or a vf30.

    EDIT: Whups! You have sti inj. stock. I guess I'll need those.

Page 1 of 4 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •