SoCal WRX FlatFour (F4) - Page 1045

This is a discussion on SoCal WRX FlatFour (F4) within the South Western States forums, part of the Regional Discussion category; What a loooooong day yesterday... after all the stock parts were back in, the bottem rubber oil return line popped ...

  1. #15661
    Registered User volcomsoldier19's Avatar
    Join Date
    Mar 2005
    Location
    SoCal, Whales ******
    Posts
    1,590
    What a loooooong day yesterday...

    after all the stock parts were back in, the bottem rubber oil return line popped off or wasnt seated correctecly, so 2.7qts of oil drained on the driveway....so in one hour Anson and I pulled the IC and turbo to get the hose on correctly, I'm in a way glad it happened so now I know what to look for when doing these things

    The stock turbo makes a horrid sound though when boosting
    it sounds like when there's a mosquito in your ear...it boosts, there's power
    but i maybe pulling the turbo again to replace it....ughh

    Anson, thanks for your help and sticking it out until the end...
    Quote Originally Posted by ansonowicz View Post
    So if I'm stuck in a rut or something, it's mostly because I made a wrong decision somewhere and I need to correct myself out of it.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #15662
    Registered User ansonowicz's Avatar
    Join Date
    Oct 2005
    Location
    LBC
    Posts
    2,262
    Quote Originally Posted by volcomsoldier19 View Post
    after all the stock parts were back in, the bottem rubber oil return line popped off or wasnt seated correctecly, so 2.7qts of oil drained on the driveway...
    It's something I was aware of while I was installing & felt bad I didn't triple check instead of only double checking.

    Definitely know for next time. I'm glad it worked out and perhaps you can sell the darn thing as is. After all, you're hearing the sound of the turbo That's what mine sounds like, but I'm sure it's normal
    F4.21 have root access, will travel
    :wq! 6MT20G


    Quote Originally Posted by volcomsoldier19 View Post
    long haul, the wagon will give you happiness in the times of madness...

  4. #15663
    Registered User ansonowicz's Avatar
    Join Date
    Oct 2005
    Location
    LBC
    Posts
    2,262
    Quote Originally Posted by WRX13oy View Post
    so.. i couldnt make it cas my car wasnt drivable due to a pulley malfunction
    Did the pully malfunction or was the belt old & shredded? How many miles are on the belt & pulley? I know your block is relatively new, but I'm a bit worried since I'm hitting the 68k mark.
    F4.21 have root access, will travel
    :wq! 6MT20G


    Quote Originally Posted by volcomsoldier19 View Post
    long haul, the wagon will give you happiness in the times of madness...

  5. #15664
    Registered User WRX13oy's Avatar
    Join Date
    Jul 2003
    Location
    SOCAL!! 91752
    Posts
    6,979
    Quote Originally Posted by ansonowicz View Post
    Did the pully malfunction or was the belt old & shredded? How many miles are on the belt & pulley? I know your block is relatively new, but I'm a bit worried since I'm hitting the 68k mark.
    the bearing in the pulley seized and it caused the belt to melt the pulley like that. i just took it off for now since its winter and i dont need my a/c. The pulley has about 90k miles on it since sam at GT reused most of my old hardware from my old engine.
    SOCAL F4#02 OG member

    2002 PSM WRX stage 6
    2007 Kawasaki Ninja ZX6R

  6. #15665
    Registered User volcomsoldier19's Avatar
    Join Date
    Mar 2005
    Location
    SoCal, Whales ******
    Posts
    1,590
    Quote Originally Posted by ansonowicz View Post
    It's something I was aware of while I was installing & felt bad I didn't triple check instead of only double checking.

    Definitely know for next time. I'm glad it worked out and perhaps you can sell the darn thing as is. After all, you're hearing the sound of the turbo That's what mine sounds like, but I'm sure it's normal
    the sound im hearing is a dying turbo

    i think it was DOA when we installed it

    I may get my stocker back from Jasmin, the one that came in my car.


    But now i've got a coolant leak

    I think it's the radiator but i'm not sure

    I'm really frustrated with the car.....
    Quote Originally Posted by ansonowicz View Post
    So if I'm stuck in a rut or something, it's mostly because I made a wrong decision somewhere and I need to correct myself out of it.

  7. #15666
    Registered User Fahren's Avatar
    Join Date
    Nov 2005
    Location
    Garden Grove, CA
    Posts
    0
    update.

    got the vf39 into the fozzie.

    jason and i are both getting the same whiney sound.
    so we're figuring it's just a leak somewhere.
    SoCal F4 #22 Shoes
    Quote Originally Posted by Forester 2.5 XTi View Post
    If aesthetics was 1st, I wouldn't have bought a Forester!

  8. #15667
    Registered User volcomsoldier19's Avatar
    Join Date
    Mar 2005
    Location
    SoCal, Whales ******
    Posts
    1,590
    Quote Originally Posted by Fahren View Post
    update.

    got the vf39 into the fozzie.

    jason and i are both getting the same whiney sound.
    so we're figuring it's just a leak somewhere.
    yea i think i'm going to replace my header to up pipe gasket and also my Y pipe, and check the turbo inlet.

    I'm replacing my radiator tomorrow, I think that's where i'm leaking from, I noticed the seams are crusty ( dried coolant )

    If it still leaks after that, than I am clueless.

    the two coolant hoses going to the turbo are seated tight and not leaking.
    Quote Originally Posted by ansonowicz View Post
    So if I'm stuck in a rut or something, it's mostly because I made a wrong decision somewhere and I need to correct myself out of it.

  9. #15668
    Registered User ansonowicz's Avatar
    Join Date
    Oct 2005
    Location
    LBC
    Posts
    2,262
    Quote Originally Posted by volcomsoldier19 View Post
    yea i think i'm going to replace my header to up pipe gasket and also my Y pipe, and check the turbo inlet.

    I'm replacing my radiator tomorrow, I think that's where i'm leaking from, I noticed the seams are crusty ( dried coolant )

    If it still leaks after that, than I am clueless.

    the two coolant hoses going to the turbo are seated tight and not leaking.
    possibly the Downpipe gasket as well? good luck dudes.
    F4.21 have root access, will travel
    :wq! 6MT20G


    Quote Originally Posted by volcomsoldier19 View Post
    long haul, the wagon will give you happiness in the times of madness...

  10. #15669
    Registered User volcomsoldier19's Avatar
    Join Date
    Mar 2005
    Location
    SoCal, Whales ******
    Posts
    1,590
    Quote Originally Posted by ansonowicz View Post
    possibly the Downpipe gasket as well? good luck dudes.
    yea might as well replace it too
    Quote Originally Posted by ansonowicz View Post
    So if I'm stuck in a rut or something, it's mostly because I made a wrong decision somewhere and I need to correct myself out of it.

  11. #15670
    Registered User volcomsoldier19's Avatar
    Join Date
    Mar 2005
    Location
    SoCal, Whales ******
    Posts
    1,590
    little update

    my radiator was not leaking...
    the coolant leak is coming out of the DP where the turbo bolts up to it
    I was given a bad turbo maybe...the person I got it from agreed to pay half for a new stock one, fine with me...I just want a non-leaking car.

    replaced the dp gasket today and I still have the noise...so onto replacing more gaskets...
    Quote Originally Posted by ansonowicz View Post
    So if I'm stuck in a rut or something, it's mostly because I made a wrong decision somewhere and I need to correct myself out of it.

  12. #15671
    Registered User ansonowicz's Avatar
    Join Date
    Oct 2005
    Location
    LBC
    Posts
    2,262
    Quote Originally Posted by volcomsoldier19 View Post
    little update

    my radiator was not leaking...
    the coolant leak is coming out of the DP where the turbo bolts up to it
    I was given a bad turbo maybe...the person I got it from agreed to pay half for a new stock one, fine with me...I just want a non-leaking car.

    replaced the dp gasket today and I still have the noise...so onto replacing more gaskets...
    damn, what a pain in the arse.
    F4.21 have root access, will travel
    :wq! 6MT20G


    Quote Originally Posted by volcomsoldier19 View Post
    long haul, the wagon will give you happiness in the times of madness...

  13. #15672
    Registered User volcomsoldier19's Avatar
    Join Date
    Mar 2005
    Location
    SoCal, Whales ******
    Posts
    1,590
    Quote Originally Posted by ansonowicz View Post
    damn, what a pain in the arse.

    ur telling me, I thinking about just taking the car with a new stock turbo and gaskets to this suby mechanic shop and saying have at it...
    Quote Originally Posted by ansonowicz View Post
    So if I'm stuck in a rut or something, it's mostly because I made a wrong decision somewhere and I need to correct myself out of it.

  14. #15673
    Registered User WRX13oy's Avatar
    Join Date
    Jul 2003
    Location
    SOCAL!! 91752
    Posts
    6,979
    hey ron, i think you were spotted on nasioc
    Quote Originally Posted by iheartscoobys View Post
    Spotted another one leaving the main place mall and turning right onto main st..

    You: white 04/05 with a pink so cal flat 4 sticker that looks like the sti logo on ur drivers door, nice exhaust, wingless and a notw sticker on the corner of the back window

    Me: passenger of my gfs scion xb starring at you hahah
    SOCAL F4#02 OG member

    2002 PSM WRX stage 6
    2007 Kawasaki Ninja ZX6R

  15. #15674
    Registered User Fahren's Avatar
    Join Date
    Nov 2005
    Location
    Garden Grove, CA
    Posts
    0
    well after making it to a grand total of 14.3lbs of boost on the 39 my clutch is starting to slip now

    i've got an almost brand new exedy sitting in the wagon still, are the 2.0 clutches interchangable with the 2.5 blocks?
    SoCal F4 #22 Shoes
    Quote Originally Posted by Forester 2.5 XTi View Post
    If aesthetics was 1st, I wouldn't have bought a Forester!

  16. #15675
    Registered User volcomsoldier19's Avatar
    Join Date
    Mar 2005
    Location
    SoCal, Whales ******
    Posts
    1,590
    Quote Originally Posted by Fahren View Post
    well after making it to a grand total of 14.3lbs of boost on the 39 my clutch is starting to slip now

    i've got an almost brand new exedy sitting in the wagon still, are the 2.0 clutches interchangable with the 2.5 blocks?

    14.3...wait until you hit 17 on a tune...:drools:

    i think the clutches are, but the flywheels are not...
    Quote Originally Posted by ansonowicz View Post
    So if I'm stuck in a rut or something, it's mostly because I made a wrong decision somewhere and I need to correct myself out of it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •