For Sale OEM iPod interface. H621SSC201
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on OEM iPod interface. H621SSC201 within the Personal For Sale & Wanted forums, part of the ClubWRX.net Marketplace category; This item is the stock iPod interface for a 2008 Subaru. I bought it for my Impreza but it should ...

  1. #1
    Registered User
    Join Date
    Jan 2012
    Posts
    13

    Thumbs up OEM iPod interface. H621SSC201

    This item is the stock iPod interface for a 2008 Subaru. I bought it for my Impreza but it should fit other models as well if you check with Subaru. It is used but is still in perfect condition with all the fasteners and manuals. I am replacing the entire head unit, which this interface would not be compatible with it. I used it for about a month so it will have no issue.

    Part number: H621SSC201

    Please buy!!!

    $140 or best offer, just trying to get it off my hands and make some of the money back.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jan 2012
    Posts
    13
    BUMP!!

    Come on I'll sell for cheaper than 100$ I just don't want to have an extra piece of equipment.

  4. #3
    Registered User Jd617x's Avatar
    Join Date
    Feb 2012
    Posts
    29
    $60 cash now!!

  5. #4
    Registered User
    Join Date
    Jan 2012
    Posts
    13
    Sorry. I sold it a couple days ago on Ebay.

  6. #5
    Registered User
    Join Date
    Nov 2011
    Location
    Medina, Ohio, United States
    Posts
    2
    Hey. I hope you dont mind me asking so late but I bought one off of ebay and it seems I have an extra wire and the pod doesnt really work. Any clues?

  7. #6
    Registered User
    Join Date
    Jan 2012
    Posts
    13
    Sorry for the late reply. I had a similar issue. The OEM set up works by using your presets to categorize your songs. So like preset one is to play just albums, and then you use the volume knop to sort through. Its kind of a Pain in the you know what. One of the reasons I got rid of it. The extra cable I'm not sure about. It might be a grounding wire or a hook-up for an adapter.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •