not a happy camper
Page 1 of 2 12 LastLast
Results 1 to 15 of 29

This is a discussion on not a happy camper within the North Western States forums, part of the Regional Discussion category; I'm not a happy camper, On the way back from the run on sunday I did kind of a hard ...

  1. #1
    Registered User jdkrocksit's Avatar
    Join Date
    Sep 2006
    Location
    Clackamas, OR
    Posts
    270

    Angry not a happy camper

    I'm not a happy camper, On the way back from the run on sunday I did kind of a hard pull getting on the freeway near woodland and heard a little pop then lost boost Oh sh*t I thought I just lost my turbo. I got off of it then cruised for a little bit under no boost and waited to see if i was going to get any lights or any type of gauge movements, but nothing happened. I drove for about 5-6 min keeping the RPM really low and had no issues so I then got back on it aging and had some boost but slow and kind of weak. I got back home no problem and no issues, but now I'm worried that i may have just screwed up my turbo. I have been thinking about going to a 16G or VF39 turbo set up for a while now and just have been putting it off. I have not taken it in to the shop yet becasue i'm pretty sure of what it is, and I know that i'm looking at some big $$$ soon. Has anyone gone with ethier of these set ups in there 02 WRX personaly? and what kinds of things have you liked or disliked about it?
    2002 WRX
    14.8 @ 91.1mph 1/4mile @ 189WHP (stock)
    Looking for another car soon

    PROUD PRE CUSTOMER Different strokes (crew member)

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User SRT4-2NV's Avatar
    Join Date
    Jan 2005
    Location
    Portland
    Posts
    136
    Probably just a boost leak or vacuum line. also check the clamp that goes to the top mount.
    2004 Srt-4
    309/365 almost stock <<<SOLD>>>
    Different Strokes

    2006 Black Honda S2000
    210/145 Stock

  4. #3
    Registered User Thug Nasty's Avatar
    Join Date
    Jul 2006
    Location
    Denver CO / Portland OR
    Posts
    185
    Sounds like a boost leak. Good luck.
    -John
    Different Strokes
    Dirty Crew #2002
    Mods in profile.

  5. #4
    Resident meany-rator 06wrx4me's Avatar
    Join Date
    Jun 2006
    Location
    Nor Cal
    Posts
    11,433
    I Support ClubWRX
    What kinda boost tubes you running?
    2014 Ford Fiesta ST

    06 WRX, HAWKEYE # 001 <T-boned and sold>

    COILOVER TABLE
    TURBO TABLE

  6. #5
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    + 1 for boost leak
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  7. #6
    Registered User Super_HKS's Avatar
    Join Date
    Jun 2007
    Posts
    1,475
    Vac lines/ check the intercooler clamps
    Previous owner of Rubie a 2005 WRX
    New owner of Molly a 2009 WRX
    Rally armor UR FTW/Red tail light mod w/insert
    **Catback in 2 months!

  8. #7
    Registered User BlueBlurr13's Avatar
    Join Date
    Oct 2007
    Location
    Puyallup
    Posts
    149
    Check ur blow off valve also... same thing happened to me but my car just shut off because my bov poped off. just an idea.. maybe just a bolt or something broke.??
    _2002 Bugeye Blue + Black
    _Stage 2
    _eBay Bay Cat Back 3"
    _STi Top Mount =)
    _Broke down in the shop

    Quote Originally Posted by 03WRX_YELLOW View Post
    Remember last time you thought you had something wrong with your car cause you couldnt boost all the way ... you had your floor mat stuck under your gas pedal.

  9. #8

    Princess Moderator

    03WRX_YELLOW's Avatar
    Join Date
    May 2004
    Location
    Gresham, Oregon
    Posts
    14,843
    I Support ClubWRX
    you should have bobby look at it. Remember last time you thought you had something wrong with your car cause you couldnt boost all the way ... you had your floor mat stuck under your gas pedal. So, I'd just ask bobby to look over it for you. Find out for sure if its the turbo. Cause you may have more time to save up for a turbo and be able to do more research on which you'd like to do.
    Jennifer - "Consigliere" for the Bugeye Mafia
    ScoobyDMCtt - Blobeye Syndicate #007
    04 STi ECU - with Protune - FSTi Garrett GT40 -- 422whp-more to come... 12.86 @ 105

    BoBBy TuNED@ preracing.com --- DIFFERENT STROKES

  10. #9
    Registered User BlueBlurr13's Avatar
    Join Date
    Oct 2007
    Location
    Puyallup
    Posts
    149
    Quote Originally Posted by 03WRX_YELLOW View Post
    Remember last time you thought you had something wrong with your car cause you couldnt boost all the way ... you had your floor mat stuck under your gas pedal. do.
    thats funny right there =)
    _2002 Bugeye Blue + Black
    _Stage 2
    _eBay Bay Cat Back 3"
    _STi Top Mount =)
    _Broke down in the shop

    Quote Originally Posted by 03WRX_YELLOW View Post
    Remember last time you thought you had something wrong with your car cause you couldnt boost all the way ... you had your floor mat stuck under your gas pedal.

  11. #10
    Would Never, Ever Say Something Bad About an Admin's Mom SonicWagon's Avatar
    Join Date
    Jul 2007
    Location
    Santa Cruz New Mexico
    Posts
    5,742
    Quote Originally Posted by BlueBlurr13 View Post
    thats funny right there =)
    +1
    "It is at our most challenging times that we must cheat our very hardest" - Eric Theodore Cartman
    Quote Originally Posted by Weasel 555 View Post
    so whose up for been banned?
    Quote Originally Posted by RayfieldsWRX View Post
    I is teh b1ggest douche evarrrr!~

  12. #11
    Registered User Deathrin's Avatar
    Join Date
    Sep 2007
    Location
    Bloomington, MN
    Posts
    224
    Quote Originally Posted by 03WRX_YELLOW View Post
    you should have bobby look at it. Remember last time you thought you had something wrong with your car cause you couldnt boost all the way ... you had your floor mat stuck under your gas pedal.
    ZOMG ROFL now everyone in my office thinks im crazy... its ok i wont go into some of the things i have done...

  13. #12
    Registered User Super_HKS's Avatar
    Join Date
    Jun 2007
    Posts
    1,475
    [QUOTE=03WRX_YELLOW;2180375] Remember last time you thought you had something wrong with your car cause you couldnt boost all the way ... you had your floor mat stuck under your gas pedal.QUOTE]

    OH NOES!
    Previous owner of Rubie a 2005 WRX
    New owner of Molly a 2009 WRX
    Rally armor UR FTW/Red tail light mod w/insert
    **Catback in 2 months!

  14. #13

    Peachypumpkincheeks

    Speedette's Avatar
    Join Date
    Aug 2005
    Location
    Sterling, Virginia
    Posts
    8,615
    Quote Originally Posted by 03WRX_YELLOW View Post
    you should have bobby look at it. Remember last time you thought you had something wrong with your car cause you couldnt boost all the way ... you had your floor mat stuck under your gas pedal.


    That's the floormat accessport mod! Documented here:
    http://www.clubwrx.net/forums/showthread.php?t=77710
    Heather | 2002 WRX | Stage 2
    ScoobyDMCtt | Official Bodyguard #2 for the Bugeye Mafia
    TastesLikeAwesome | @Subiestar

  15. #14
    Registered User BlueBlurr13's Avatar
    Join Date
    Oct 2007
    Location
    Puyallup
    Posts
    149
    Sorry 03 WRX i had to use that as my signature thats purrty dang funny
    _2002 Bugeye Blue + Black
    _Stage 2
    _eBay Bay Cat Back 3"
    _STi Top Mount =)
    _Broke down in the shop

    Quote Originally Posted by 03WRX_YELLOW View Post
    Remember last time you thought you had something wrong with your car cause you couldnt boost all the way ... you had your floor mat stuck under your gas pedal.

  16. #15
    Registered User jdkrocksit's Avatar
    Join Date
    Sep 2006
    Location
    Clackamas, OR
    Posts
    270
    NOPE NOPE I checked the floor mat this time first It for sure was not the floor mat. I checked my connector to my TMIC and didnt find anything loose, checked the BOV and its all tight. I'm allso having a very strong fuel smell when its cold. I guess its just time to take it in to the shop and have them fix that dang thing.
    2002 WRX
    14.8 @ 91.1mph 1/4mile @ 189WHP (stock)
    Looking for another car soon

    PROUD PRE CUSTOMER Different strokes (crew member)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •