A few Questions about '04 wrx
+ Reply to Thread
Results 1 to 12 of 12

This is a discussion on A few Questions about '04 wrx within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; I'm new to this site and just had a few questions--If I've posted in the wrong place I'm sure someone ...

  1. #1
    Registered User
    Join Date
    Nov 2006
    Posts
    4

    A few Questions about '04 wrx

    I'm new to this site and just had a few questions--If I've posted in the wrong place I'm sure someone will redirect me.

    I just bought an '04 wrx and love it! I did, however, notice on the engine there are about three hoses disconnected in front of the innercooler. I will put up a picture in a while. Is that normal? or some kind of "free mod"?

    thanks.
    Attached Thumbnails Attached Thumbnails DSCF1596.jpg  
    Last edited by scrud; 11-27-2006 at 11:50 AM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    GraysonSubaru's Avatar
    Join Date
    May 2005
    Location
    Knoxville, TN
    Posts
    4,686
    post pictures when you can..try to point to what you are talking so we can figure out what is normal and what is not on your car..
    Quote Originally Posted by RayfieldsWRX View Post
    Hey, being the forum car ADD guy is better than being the forum OG.
    Quote Originally Posted by Mikie13 View Post
    Well nobody cares what you think, Seth

  4. #3
    Moderator
    Join Date
    Jul 2003
    Location
    Maryland
    Posts
    11,098
    I Support ClubWRX
    Probaly a BOV or BC connections someone left when they took the parts off.
    0-60 faster then your first sexual experience.
    "You've come far, and though you're far from the end
    You don't mind where you are, cause you know where you've been"

  5. #4
    Registered User
    Join Date
    Nov 2006
    Posts
    4

    picture

    I attached a picture to the first post so hopefully it will show up ok.

  6. #5
    GraysonSubaru's Avatar
    Join Date
    May 2005
    Location
    Knoxville, TN
    Posts
    4,686
    thanks for the picture..let me go take one of mine.
    Quote Originally Posted by RayfieldsWRX View Post
    Hey, being the forum car ADD guy is better than being the forum OG.
    Quote Originally Posted by Mikie13 View Post
    Well nobody cares what you think, Seth

  7. #6
    GraysonSubaru's Avatar
    Join Date
    May 2005
    Location
    Knoxville, TN
    Posts
    4,686
    some of mine...(mine is a 2003)
    Last edited by GraysonSubaru; 12-13-2006 at 10:15 AM.
    Quote Originally Posted by RayfieldsWRX View Post
    Hey, being the forum car ADD guy is better than being the forum OG.
    Quote Originally Posted by Mikie13 View Post
    Well nobody cares what you think, Seth

  8. #7
    GraysonSubaru's Avatar
    Join Date
    May 2005
    Location
    Knoxville, TN
    Posts
    4,686
    from looking at the pictures, it looks like those rubber hoses should be connected to the metal hose right by them.

    i have higher resolution pictures of what I just posted if you want me to email them to you (would need your email address) if you cant see them in the posted ones.
    Quote Originally Posted by RayfieldsWRX View Post
    Hey, being the forum car ADD guy is better than being the forum OG.
    Quote Originally Posted by Mikie13 View Post
    Well nobody cares what you think, Seth

  9. #8
    Registered User powder's Avatar
    Join Date
    Aug 2006
    Location
    WA State
    Posts
    3,595
    I would say that if they reach, reattach them.
    Blobeye Syndicate #2004
    Military Militia #30-06

    2004 WRX - JBP:Stage 2:13.93 @ 96

    Wingless alas. Too bad it took a 50 ton truck to make it happen.

  10. #9
    Registered User
    Join Date
    Nov 2006
    Posts
    4
    from looking at the pictures, it looks like those rubber hoses should be connected to the metal hose right by them.

    GraysonSubaru--Thanks for the pictures. I think you're right. I will reconnect them. Do you guys know what the purpose of those are?or why someone would disconnect them?


    Thanks

  11. #10
    GraysonSubaru's Avatar
    Join Date
    May 2005
    Location
    Knoxville, TN
    Posts
    4,686
    Quote Originally Posted by scrud View Post
    from looking at the pictures, it looks like those rubber hoses should be connected to the metal hose right by them.

    GraysonSubaru--Thanks for the pictures. I think you're right. I will reconnect them. Do you guys know what the purpose of those are?or why someone would disconnect them?


    Thanks
    no problem.

    no idea why they would be disconnected..maybe someone else that knows a bit more will chime in on that one.
    Quote Originally Posted by RayfieldsWRX View Post
    Hey, being the forum car ADD guy is better than being the forum OG.
    Quote Originally Posted by Mikie13 View Post
    Well nobody cares what you think, Seth

  12. #11
    Registered User wakeskate23488's Avatar
    Join Date
    Mar 2006
    Location
    Ocean County, NJ
    Posts
    298
    um attach those

  13. #12
    Registered User Ballz's Avatar
    Join Date
    Aug 2006
    Location
    Paintbooth
    Posts
    349
    Quote Originally Posted by scrud View Post
    I'm new to this site and just had a few questions--If I've posted in the wrong place I'm sure someone will redirect me.

    I just bought an '04 wrx and love it! I did, however, notice on the engine there are about three hoses disconnected in front of the innercooler. I will put up a picture in a while. Is that normal? or some kind of "free mod"?

    thanks.
    Um, yea you might want to reattach those hoses to where they belong.. Didn't you check the car out prior to buying it? I'm surprised your car even runs right without those hoses disconnected.
    Maybe next time bring your dad with you or something, or learn how to look over a used car a little more carefully before buying it.. If I had seen that on a car I was looking to buy I would have passed it up, wondering what else could be disconnected somewhere else that you can't see, or if there's something that is majorly *****ed that just has some sort of quick fix...

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •