Screeching Sounds..
Results 1 to 6 of 6

This is a discussion on Screeching Sounds.. within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Alright so i have a 2002 WRX with a VF34, sti pinks, walbro fuel pump, catless downpipe, catless tbe, and ...

  1. #1
    Registered User LiveWire401's Avatar
    Join Date
    Jun 2006
    Location
    Washington
    Posts
    12

    Screeching Sounds..

    Alright so i have a 2002 WRX with a VF34, sti pinks, walbro fuel pump, catless downpipe, catless tbe, and Cobb AP.. Ok so got all that installed, drove it around for maybe.. 20 miles and started gettings this loud highpitched screeching sound at higher boost levels, got a few opinons and we decided that there was a leak/hole in the turbo inlet hose. So after a little while got a Perrin Inlet hose and installed that (which was a terrible experience) Fired it up and we have the exact same sound, maybe slightly different pitch but occurs under the same circumstances. So any other ideas? Checked for over boost and everything seems to be with in maybe +/- 0.5lbs so I dont think thats an issue. Anyway I dont know too much about this stuff so any suggestions or help would be great! Thanks!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Banned
    Join Date
    Sep 2006
    Posts
    124

    intercoler

    your intercoler is probley leaking check thte hoses going to that replace them

  4. #3
    Registered User D0WNxSH1FT's Avatar
    Join Date
    Oct 2004
    Location
    Westchester Cnty, NY
    Posts
    6,545
    Are you sure its not just the turbo spooling? Do you have an exhaust that is loud? If not then you might be hearing it spool. The new DP is made of thinner material than stock so it doesnt muffle the sound. It does have a loud high pitched metallic sound at higher RPM levels.
    2008 Satin White Pearl WRX Sedan w/ Navi
    2005 San Remo Red WRX Sedan w/ VF34 (traded)
    Pi Kappa Alpha | New England Flat 4

  5. #4
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,591
    I Support ClubWRX
    A loud screech under boost, is normally a leaking uppipe, or the EGT sensor has backed out of the uppipe.
    Does it get worse when the car is warm?

  6. #5
    Registered User LiveWire401's Avatar
    Join Date
    Jun 2006
    Location
    Washington
    Posts
    12

    screeching sounds..

    I'll double check the hoses to the intercooler, I've had it off numerous times to try to find the problem and everything seemed to be fine with those. I'm sure its not the turbo spooling I can hear it spool as boost builds with heavier throttle then I hear the screech. I will get under there and check the uppipe I did forget to mention its a TurboXS uppipe, it sounds higher up than that (closer to the hood) but certainly a possibility. Sorry for the igorance here but the EGT sensor would be that thing I screwed into the side of the uppipe? I'm not sure about the getting worse when warm, I dont usually drive with enough throttle to cause the issue while the car is cold but I'll try that too and see if there is a difference. Thanks for the imput, I'll get another post up when I've checked the suggestions. Side note, i should mention there was a nice sized whole in the stock inlet hose under the hose clamp as we expected. Thanks again

  7. #6
    ODJ
    ODJ is offline
    Registered User ODJ's Avatar
    Join Date
    Jan 2006
    Location
    Tampa, FL
    Posts
    357
    Quote Originally Posted by LiveWire401 View Post
    the EGT sensor would be that thing I screwed into the side of the uppipe?
    Yes.
    UNSPOILT BY PROGRESS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •