I need help
Results 1 to 4 of 4

This is a discussion on I need help within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; I bought an 04 wrx about a year and a half ago , since then i've had to repalce the ...

  1. #1
    Registered User
    Join Date
    Apr 2006
    Posts
    8

    Question I need help

    I bought an 04 wrx about a year and a half ago , since then i've had to repalce the "egt" sensor twice . The car was used and had some mods done to it . From what i can tell it has an hks catback without cats , front mount intercooler , wrapped headers , an xs engineering turbo booster , my gauge says it's doing 1 bar of boost . I took it to the dealer and they said the car is running rich and it's coming up as a misfiring code when put on the diagnostics machine . Another person told me that because i have no cats the exhuast is too hot and burning up my "egt". Any help solving this problem would be appreciated . Thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    pwn
    pwn is offline
    Registered User
    Join Date
    Mar 2006
    Location
    Danville, California
    Posts
    130
    First of all id get rid of the xs engineering thing you have going on and throw a cobb AP on it. If you threw a new downpipe and uppipe on there and got a protune, I think you would be running fairly well

  4. #3
    Registered User Kush's Avatar
    Join Date
    Mar 2006
    Location
    Westchester, New York
    Posts
    1,369
    Quote Originally Posted by pwn
    First of all id get rid of the xs engineering thing you have going on and throw a cobb AP on it. If you threw a new downpipe and uppipe on there and got a protune, I think you would be running fairly well
    yeah, boost controllers are murder for the newer WRX's, get rid of that thing and get some proper engine management (or just return it to stock)
    New England F4
    www.OddTopic.net - my pet project, come say hello!
    '02 BUGEYE
    "One's level of fear is directly proportional to their preparedness for it's source"
    -Me

    DO A FRIGGIN SEARCH!!!

  5. #4
    Registered User
    Join Date
    Apr 2006
    Posts
    8
    I talked to Ferggie the guy at South Coast Subaru and he recomended that i go to cobb and get engine management to solve the problem. Thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •