My first WRX and I'm loving it!! but I need help with car sputtering
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on My first WRX and I'm loving it!! but I need help with car sputtering within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Hey Guys! I just bought a 2009 WRX Wagon from Silverline Automotive. I Love everything about the WRX. Recently I ...

  1. #1
    Registered User
    Join Date
    Oct 2013
    Location
    Portland
    Posts
    2

    My first WRX and I'm loving it!! but I need help with car sputtering

    Hey Guys! I just bought a 2009 WRX Wagon from Silverline Automotive. I Love everything about the WRX. Recently I noticed a sputtering problem. The car came with a full 3" TBE no resonators or cat. I believe it was an Nvidia. The sound was a bit too loud for me and sometimes it would back fire and smelt like it was running rich. so i had the shop put in a stock exhaust from the cat back. I also had the coil pack replaced. The car doesn't sputter in 1st or 2nd gear but in 3rd gear right before hitting boost it sputters and shakes a little. If I floor it kinda goes away. I'm not sure what is causing the problem? Idk if i need a tune or if the car had a previous tune. I have no check engine lights or anything.. Can anyone help with ideas?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Sammich Makin' Pwincess wrxtreme06's Avatar
    Join Date
    May 2007
    Location
    orlando flawduh
    Posts
    12,786
    I Support ClubWRX
    if the car was tuned for the full TBE and now you dont have one, you'll need to get the car remapped. i'd suggest taking it to a shop that specializes in tuning/building subarus so they can look over the car and find out if it's tuned or if there are any other modifications

    desiree
    your friendly, neighborhood subaru girl
    abbigale : 06 impreza wrx tr: cobb stage II
    hawkeye alliance #11:11//
    wingl3ss @ll!ance #17 // lvl 80 N.E.R.D.

  4. #3
    Registered User wreckingball man's Avatar
    Join Date
    Jul 2012
    Location
    Rocky Top
    Posts
    2,324
    ^This. Glad you like it. Hope you get that fixed and Welcome

  5. #4
    Registered User
    Join Date
    Oct 2013
    Location
    Portland
    Posts
    2
    Quote Originally Posted by wreckingball man View Post
    ^This. Glad you like it. Hope you get that fixed and Welcome

    Thanks Guys! I'm going to take to PRE and see if they can reflash it to stock ecu, I hope thats the problem. I remember now that it sputtered even with the TBE on the car...

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •