Looking for a answer?
Results 1 to 15 of 15

This is a discussion on Looking for a answer? within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; So I just bought my wrx few weeks ago. This cable dangling down at the passenger side below the glove ...

  1. #1
    Registered User flytime's Avatar
    Join Date
    Jul 2013
    Location
    Wisconsin
    Posts
    56

    Looking for a answer?

    So I just bought my wrx few weeks ago. This cable dangling down at the passenger side below the glove compartment has left me wondering what it is.
    Is this cable or what ever it's called some kind of tuning cable?


    04 Impreza Wrx

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EndlessSea's Avatar
    Join Date
    Nov 2012
    Location
    Las Vegas
    Posts
    423
    what year wrx?

    what known mods are on the car?(if any)

    just a guess. but it looks like a cable used to tune your car from a laptop. maybe they ran it fromthe OBD2 port and through the dash and out the glovebox? is the other end plugged into your OBD2 port?

    im not 100% familiar with older wrx's(your sig says 04 so im assuming here given the lack of information in your post). so idk if they had a way to burn a chip onto the ecu and have a cable come directly off that. similiar to a hondata/kpro/crome type tuning solution in the honda world.

    check where it runs too.
    2013 wrx sedan(saving up for a 2015 STI)

    Previous faist cars: '05 Mustang GT '02 RSX-S, '91 SR20 240sx, '85 300zx turbo

  4. #3
    Registered User flytime's Avatar
    Join Date
    Jul 2013
    Location
    Wisconsin
    Posts
    56
    Sorry for the lack of info. The previous owner have told me he had a shop install aftermarket parts in the car and tuned. Probably a stage one. It has an cold air intake, a completely exhaust system. Grimspeed. Its a 2004 impreza wrx. I'll check it now.
    04 Impreza Wrx

  5. #4
    and the Funky Bunch Calvinball's Avatar
    Join Date
    Jan 2012
    Location
    Philly Area
    Posts
    5,963
    Quote Originally Posted by flytime View Post
    Sorry for the lack of info. The previous owner have told me he had a shop install aftermarket parts in the car and tuned. Probably a stage one. It has an cold air intake, a completely exhaust system. Grimspeed. Its a 2004 impreza wrx. I'll check it now.
    If the exhaust is completely aftermarket, that would be stage 2.

    Read the thread in my sig for some background on modding these cars, and I second figuring out what that cable is plugged into. It's not a tactrix (tuning cable), pretty sure both versions use usb connections. I think the vagcom cables do too, but I'm not sure.
    - Will
    First Mods: What to do and what not to do
    Current Car: 2014 Golf TDI
    Previous Cars:2012 WRB WRX Hatch, 2004 RSX-S, 1998 Grand Prix GTP
    "Isn't it amazing how smart you feel when you just aren't being stupid?"

  6. #5
    Resident meany-rator 06wrx4me's Avatar
    Join Date
    Jun 2006
    Location
    Nor Cal
    Posts
    11,420
    I Support ClubWRX
    Edit: didn't see pic at work, def a serial cable.
    Last edited by 06wrx4me; 07-31-2013 at 02:20 PM.
    2014 Ford Fiesta ST

    06 WRX, HAWKEYE # 001 <T-boned and sold>

    COILOVER TABLE
    TURBO TABLE

  7. #6
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,027
    I Support ClubWRX I Support ClubWRX
    Kinda looks like a serial cable.. the TurboXS UTEC used serial cable to interface.

  8. #7
    Registered User Ingo's Avatar
    Join Date
    Mar 2012
    Location
    Colorado Springs, CO
    Posts
    1,110
    From here it sure looks like a serial comm connector. . . There's probably something connected to the other end. As MainFrame stated above. I would suggest to take a deeper look into the car, there are mods there that you might want to 1: just figure out or 2: change to something more up-to-date.
    You can't have everything - where would you put it?

  9. #8
    Registered User flytime's Avatar
    Join Date
    Jul 2013
    Location
    Wisconsin
    Posts
    56
    Thanks for all the input guys. I didn't have time to check where it runs through because of work. For now I know it's not hook to the OBII. Sorry guys, I'm very new to this so please excuse my dumbness haha.
    04 Impreza Wrx

  10. #9
    Registered User EndlessSea's Avatar
    Join Date
    Nov 2012
    Location
    Las Vegas
    Posts
    423
    its all good man. everybody has to start somewhere. in a few years you'll be schooling some new guys in the ways of wrx life!
    2013 wrx sedan(saving up for a 2015 STI)

    Previous faist cars: '05 Mustang GT '02 RSX-S, '91 SR20 240sx, '85 300zx turbo

  11. #10
    Registered User flytime's Avatar
    Join Date
    Jul 2013
    Location
    Wisconsin
    Posts
    56
    Quote Originally Posted by EndlessSea View Post
    its all good man. everybody has to start somewhere. in a few years you'll be schooling some new guys in the ways of wrx life!
    Thanks man. Just got out from work. Took a flashlight check to see where that serial cable ran through. Didn't seem to have luck finding the same one over at the driverside. Didn't feel like taking apart my dash. I'll get on it when I have a day off
    04 Impreza Wrx

  12. #11
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,027
    I Support ClubWRX I Support ClubWRX
    It shouldn't be going to the driver's side, it should be going to the UTEC.. mine was installed right by the factory ECU.

  13. #12
    Registered User flytime's Avatar
    Join Date
    Jul 2013
    Location
    Wisconsin
    Posts
    56
    Quote Originally Posted by MainFrame View Post
    It shouldn't be going to the driver's side, it should be going to the UTEC.. mine was installed right by the factory ECU.
    Oh yeah? where's the UTEC? and I'll check it once I get out of work. Short shift today
    04 Impreza Wrx

  14. #13
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,027
    I Support ClubWRX I Support ClubWRX
    Mine was installed right next to the factory ECU..

  15. #14
    The Member michaelwfox's Avatar
    Join Date
    Nov 2011
    Location
    North GA
    Posts
    3,530
    I Support ClubWRX
    Surprised no one has brought this up yet. You said the previous owner had a shop install parts and tune it right? Can you get the shops contact info? They will probably have documentation as to what was done and can lead you in the right direction.
    GTA:O ClubWRX Crew

    My "Build" Thread!

    2006 WRX TR
    Hawk-Eye Alliance #1856...ssshhh don't tell anyone!

  16. #15
    \_(ツ)_/ Rambo's Avatar
    Join Date
    Oct 2010
    Location
    Denial
    Posts
    4,891
    I Support ClubWRX
    If it's not a UTEC or OBD serial cable, it's quite likely a wideband O2 sensor connection.

    Does the downpipe have a wideband O2 sensor on it?
    Isaac -- 2003 WRX sedan Stg II - Gave its life for mine 6/2013.
    2007 Outback 3.0R wagon
    Proud owner of a N.E.R.D, Member 1.3810-23

    He who shall be last, shall be sideways and smiling... - Jeremy Clarkson

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •